Раздаточный материал: Введение в использование программы обработки социологической информации SPSS

Реклама
Раздаточный материал: Введение в
использование программы обработки
социологической информации SPSS
Разработано: Бакирова Айгуль для общественного фонда «Информ-Культура»
Свои замечания, предложения и пожелания направляйте специалистам
Кластерного Бюро и фонда "Информ-Культура": [email protected]
Раздаточный материал: Введение в использование программы обработки
социологической информации SPSS .................................................................................... 1
Введение .................................................................................................................................. 2
Как установить программу SPSS-11.0? .......................................................................... 3
Кратко о системных требованиях: .................................................................................. 3
Основные элементы программы SPSS ................................................................................. 3
Запуск программы. ........................................................................................................... 3
Общий вид программы. Назначение кнопок управляющих панелей. .......................... 4
Краткое описание интерфейса программы. ................................................................... 4
Описание строки инструментов ...................................................................................... 5
Ввод данных и редактирование. ............................................................................................ 6
Ввод данных и определение переменных ..................................................................... 6
Редактирование данных .................................................................................................. 8
Заключение .............................................................................................................................. 9
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
1
Введение
Во все времена надежная и достоверная информация являлась ключевым
элементом журналистики. Особенно это актуально в настоящее время, когда
стало очевидным, что проведение опросов и обследований является мощным
инструментом, позволяющим добыть эту информацию.
Оценка удовлетворенности населения или работников, выявление
предпочтений избирателей, создание и функционирование системы показателей
работы учреждения и многие другие опросы и обследования позволяют
получать точные и достоверные данные, так как это информация из первых рук
- непосредственно от населения. В связи с этим особенно важно
профессиональному журналисту приобрести
навыки
в обобщении
статистических данных и поиске скрытых закономерностей.
Одним из наиболее часто используемых в практике программ является
статистический пакет SPSS for Windows. Он выделяется своим хорошим
интерфейсом и функциональными возможностями.
Программа SPSS предоставляет пользователю широкие возможности по
статистической обработке экспериментальных данных, по формированию баз
данных (файлов данных SPSS), по их модификации, а также по созданию так
называемых отчетов, с возможностью снабжать последние графическими
иллюстрациями.
SPSS — это всеобъемлющая и гибкая система статистического анализа и
управления данными. SPSS может брать данные практически из любых типов
файлов и использовать их для создания табличных отчетов, графиков и карт
распределения, описательных статистик и сложного статистического анализа.
SPSS for Windows позволяет анализировать огромные файлы данных с
тысячами переменных. Статистические алгоритмы в точности те же, что и на
мейнфреймах (больших ЭВМ) и результаты вычислений будут полностью
совпадать.
SPSS for Windows предоставляет пользовательский интерфейс, который
сделает статистический анализ более доступным обычному пользователю и
более удобным для опытного пользователя. Простые меню и диалоговые окна
делают возможным выполнение сложного анализа без написания строк
командного языка. Редактор Данных (Data Editor) предоставляет простое и
эффективное средство ввода данных и просмотра рабочего набора данных в
виде таблицы. Кроме того, в базовую систему включена возможность
построения высококачественных графиков.
SPSS for Windows предоставляет мощную систему статистического анализа
и управления данными в графическом окружении, используя меню и простые
диалоговые окна для того, чтобы облегчить Вашу работу. Большинство проблем
могут быть решены одним щелчком мыши.
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
2
Как установить программу SPSS-11.0?
Сначала ставите английскую версию. Для этого нажмите кнопку
"Английская версия". Установка осуществляется посредством прохождения
стандартной последовательности шагов в рамках процедуры «SetUp». Если
английская установка потребует перезагрузить компьютер, тогда сделайте это.
Затем можете переходить к установке русской версии, для чего нажмите кнопку
"Русская версия". Установщик русской версии должен сам определить папку с
установленной английской версией (если вы не меняли предопределенный во
время установки путь, то это будет "C:\Program Files\SPSS").
Кратко о системных требованиях:
- рекомендуется процессор Pentium II и выше;
- RAM – 12 (не менее 12 Мб оперативной памяти);
- не менее 60 Мб свободного места на жестком диске;
- операционная система не ниже Windows 95 – 98.
(Все современные компьютеры удовлетворяют этим требованиям.)
В настоящий момент широко распространены версии программы с восьмой
по одиннадцатую. Различия в их интерфейсе и работе не слишком значительны,
и потому пособия, созданные для версии 11, вполне применимы к более ранним
версиям.
Основные элементы программы SPSS
Запуск программы.
Запуск программы осуществляется стандартно, как для всех приложений
Windows: она приводится в действие либо щелчком левой кнопки (далее –
просто щелчком) мыши по соответствующему ярлыку. Если такого ярлыка не
видно на рабочем столе, возможно, он просто на него не выведен. Тогда
программу следует искать вторым стандартным способом:
«Пуск» «Программы» - «SPSS for Windows».
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
3
Рисунок 1. Окно запроса
После того, как программа запущена, на экране возникнет, показанное на
Рис.1, окно запроса: что Вы хотите сделать? (What would you like to do?).
Например, можно открыть имеющуюся базу данных, запустить учебник (если
он есть) и т.п. Закройте это окно нажатием кнопки «Отмена/ Cancel». Если
пожелаете, чтобы при последующих запусках это окно не возникало, поставьте
соответствующий флажок.
Общий вид программы. Назначение кнопок управляющих панелей.
После проделанных действий появится окно (Рис.2), представляющее собой
общий вид программы и, одновременно, вид окна редактора данных с панелью
инструментов и пунктами меню.
Рисунок 2. Окно редактора данных
Краткое описание интерфейса программы.
В строке меню главного окна SPSS находится 10 опций:
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
4
- File/Файл содержит стандартные возможности по созданию новых
файлов, экспорту и импорту в различные форматы, выводу на печать и т.п.
Например, открытие ранее созданной базы данных осуществляется так: Файл –
Открыть – Данные, после чего появится стандартное окно для открытия файлов.
- Edit/Правка – содержит стандартные возможности редактирования
(вырезать, копировать, вставить, отменить действие).
- View/Вид – определяет внешний вид главного окна, содержит
возможности настройки строки состояния, панели инструментов, шрифтов, и
т.п.
- Data/Данные – содержит основные операции по созданию и
редактированию данных SPSS (создание новых переменных, создание шаблона
ввода данных, сортировка данных и др.)
- Transform/Трансформация – содержит операции по изменению данных
(пересчет данных, перекодирование, замена пропущенных и ошибочных
данных).
- Analyze/Анализ – здесь находятся все статистические операции, которые
может осуществлять SPSS.
- Graphs/Графики – операции по созданию графиков.
- Utilities/Сервис – дополнительные сервисные возможности по просмотру
свойств переменных, файлов данных и др.
- Window/Окно – стандартные возможности по управлению несколькими
окнами программы.
- Help/Помощь – различная справочная информация (к сожалению, не
переведенная на русский язык).
Описание строки инструментов
Ниже, под строкой меню, находится строка инструментов (Рис.3) – слева
направо представлены пиктограммы следующих операций:
1) Открыть файл.
2) Сохранить файл.
3) Печать файла.
4) Перейти к окну повтора операций (при нажатии на эту кнопку
раскрывается окно, в котором находится список запомненных программой
произведенных ранее действий SPSS, что позволяет быстро находить часто
используемые операции).
5) Отмена действия.
6) Создать диаграмму.
7) Найти/ перейти к кейсу (под кейсом в SPSS понимается содержимое
строк таблицы).
8) Показать справочную информацию о переменной.
9) Найти и перейти к… (конкретное значению данной переменной).
10) и 11) Добавить новый кейс или Добавить новую переменную.
12) Разделить данные – операция позволяет разделять данные файла по
какому-либо признаку.
13) «Взвесить кейсы».
14) Сортировать кейсы по определенным правилам.
15) Показать/ скрыть метки данных.
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
5
16) Работа с ранее выделенной группой переменных.
Строка, следующая за описанной, отражает текущее «состояние дел» в
выделенной ячейке, то есть показывает (серое поле) ее номер по строке и
столбцу (переменной) и величину значения (белое поле).
Видно, что общий вид программы SPSS внешне напоминает табличный
редактор Excel. Это действительно так, и ячейки таблицы в SPSS выделяются и
заполняются аналогично тому, как это делается в упомянутом «классическом»
табличном редакторе.
Следующая вниз строка пока содержит шапки будущих переменных – на
кнопках надписи «Var –Var –Var…» Впоследствии, после создания (или
открытия) файла данных эти надписи можно будет заменить именами
переменных.
Столбец в левой части экрана представляет собой порядковые номера строк
(кейсов), в которых будут располагаться значения соответствующих
переменных.
В нижней части главного окна имеются кнопки «Вид данных / Вид
переменной» - это способ перехода между двумя главными типами окон SPSS, о
чем будет сказано ниже.
Еще ниже расположена надпись, извещающая о готовности программы
(процессора) к работе.
Главное окно снабжено также стандартными горизонтальной и
вертикальной полосами прокрутки, что свидетельствует о том, что программой
не предусмотрены ограничения, как для количества переменных, так и для
количества значений этих переменных.
Ввод данных и редактирование.
Ввод данных и определение переменных
Для дальнейшей работы необходимо либо загрузить уже имеющиеся
данные из файла с расширением *.sav, либо ввести новые данные и, разумеется,
сохранить их в файле ИМЯ.sav . Для ввода данных и определения переменных
используются пункты основного меню Data – Define Variable (Рис.3).
При вводе каждой переменной необходимо определить:




имя переменной;
тип переменной (Type);
пропущенные значения (Missing Values);
метку переменной (Labels) – для удобства работы метку можно записать
и на русском языке;

расположение переменных в таблице (Column Format).
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
6
Рисунок 3. Окно ввода данных
Рекомендуется определить также метки значений переменной – Value Labels,
например: “0” – нет ответа, “1” – да, “2” - нет и т.п.
Для имени переменной должны выполняться следующие правила:
- имя должно начинаться с буквы, остальные символы могут быть любые;
- имя не может оканчиваться точкой или символом подчеркивания;
- длина имени не может превышать восьми знаков;
- в именах не могут использоваться пробелы или специальные символы: !, ?, *)
и т.п.;
- имена переменных нечувствительны к регистру.
Возможными типами переменной могут быть: числовой, с точкой, с запятой,
научное представление, дата, денежное представление (доллар), денежное
представление (произвольная валюта) и строковый. Форматы произвольной
валюты определяются в разделе Currency в диалоговом окне Options, доступном
из пункта меню Edit.
Метка может быть приписана каждому значению переменной. Это очень
удобно, поскольку длина имени не может превышать 8 символов, а метки
переменных могут быть длиной до 256 символов, и эти описывающие
переменные метки отображаются при выводе.
Пользователь имеет возможность определить некоторые значения данных как
пропущенные. Это очень часто оказывается полезным при выяснении причин
отсутствия информации. Например, исследователь хотел бы отделить данные,
пропущенные потому, что респондент отказался отвечать, от данных,
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
7
пропущенных потому, что данный вопрос не имел отношения к респонденту.
Значения данных, обозначенные как пользовательские пропущенные,
специально помечаются для того, чтобы исключить их из большинства
вычислений.
Редактирование данных
Диалоговое окно Templates позволяет создавать шаблоны определения
переменных (Рис. 4) и применять их при вводе.
Рисунок 4. Диалоговое окно определения шаблона переменной
Данные вводятся в любом порядке - по наблюдениям или по переменным, для
выбранных областей или для отдельных ячеек. Активная ячейка выделяется
жирной рамкой. Значения данных не записываются, пока пользователь не
нажмет на Enter или не выберет другую ячейку. Для ввода данных типа,
отличного от простого числового, необходимо сначала определить тип
переменной.
После ввода данных их необходимо обязательно сохранить на жестком диске в
файле с оригинальным именем и расширением *.sav : File – Save As…
Введенные данные можно редактировать с помощью Редактора Данных,
который позволяет:
o
o
o
o
o
Изменять значения данных.
Вырезать, копировать, вставлять значения данных
Добавлять и удалять наблюдения и\или переменные
Изменять порядок или определения переменных
Проводить поиск значений данных, переходить к определенному
наблюдению.
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
8
Рисунок 5. Опции редактора данных (пункт меню Edit)
В программе SPSS имеются также средства для работы с файлами данных в
различных форматах. В частности, программа обеспечивает доступ к
электронным таблицам, созданным в Lotus 1-2-3 или Excel, к файлам баз
данных, созданным в системе dBASE и различных форматах SQL, к текстовым
файлам данных.
Заключение
В этом модуле мы узнали о том, как надо правильно устанавливать
программу SPSS, какие основные системные требования предъявляются к ПК
для того, чтобы программа могла функционировать и как надо производить
запуск программы. Главная часть модуля была посвящена знакомству с
основными элементами программы SPSS. В этой части мы получили
представление об общем виде программы, о назначении кнопок управляющих
панелей, а также получили описание интерфейса программы и строки
инструментов. Кроме того, мы узнали, как производится ввод и редактирование
данных.
308847137
Last updated 29 January 2016
Available online from http://www.itrainonline.org/
9
Скачать