Загрузил Валерий Рязанов

Проектирование технологии изготовления деталей в CAD-CAM системе 1

Реклама
1
Министерство образования и науки Ульяновской области
областное государственное бюджетное образовательное учреждение
среднего профессионального образования
«Димитровградский технический колледж»
МЕТОДИЧЕСКОЕ ПОСОБИЕ
Проектирование технологии изготовления деталей в
CAD-CAM системе
Димитровград
2019 г.
2
Методическое пособие предназначено для освоения проектирования технологии
изготовления изделий для различных видов обработки на станках с ЧПУ и получения
управляющих программ в CAD/CAM системе EdgeCAM. Пособие содержит
последовательность действий: по созданию контуров изделий, по разработке технологии
обработки заготовок различной конфигурации для оборудования с ЧПУ.
Предлагаемый материал будет полезен студентам, технологам-программистам и всем тем,
кто занимается разработкой управляющих программ для станков с ЧПУ.
Организация-разработчик: областное государственное бюджетное образовательное
учреждение среднего профессионального образования «Димитровградский технический
колледж»
РАССМОТРЕНО
на заседании цикловой комиссии
«Общепрофессиональные
дисциплины и профессиональные
модули укрупненной группы
профессий и специальностей
«Машиностроение»
Председатель комиссии
И. Ю. Силуянова
подпись
Протокол заседания ЦК
№_______ от «__»________20___г
РЕКОМЕНДОВАНО
научно-методическим советом
ОГБПОУ «ДТК»
Протокол № ___________________
от «____»________________20___г.
Разработчик:
Рязанов В.М. - преподаватель дисциплин общепрофессионального цикла ОГБПОУ «ДТК»
Ф.И.О., ученая степень, звание, должность,
Рецензент:
Власов С.Н. – кандидат технических наук, доцент, заведующий кафедрой: «Технология
машиностроения» ДИТИ НИЯУ МИФИ
Ф.И.О., ученая степень, звание, должность
3
Содержание
Введение
1. Работа с осями координат в CAD/CAM системе
2. Проектирование контуров изделий в CAD/CAM системе
3. Проектирование токарной обработки в CAD/CAM системе
4. Проектирование сверлильной и фрезерной обработки в
CAD/CAM системе
5. Проектирование электроэрозионной обработки в CAD/CAM
системе
Литература
Приложения
5
7
15
21
37
40
4
Введение
Подготовка УП является процессом переработки информации, эффективным
средством автоматизации которого служит ПЭВМ (компьютер). Применение
компьютера значительно сокращает трудоемкость и повышает качество УП,
но требует разработки специального программно-математического
обеспечения (ПМО) для решения геометрических и технологических задач,
подготовки УП и проблемно-ориентировочный язык для записи и ввода в
компьютер исходной информации. Это ПМО принято называть системой
автоматизации программирования (САП) для станков с ЧПУ. Одним из
наиболее совершенным САП, для станков с ЧПУ различных моделей,
является EdgeCAM.
EdgeCAM - это пакет программ и набор сервисных подпрограмм,
разработанных компанией Pathtrace Ltd. Эти программы и подпрограммы
позволяют в удобной форме получать ЧПУ-коды для фрезерной, токарной и
электроэрозионной обработки заготовок. Это программное обеспечение
полностью совместимо с операционными системами Windows и UNIX. Оно
разработано с использованием 32-64 битной архитектуры. Функциональные
возможности этого пакета полностью удовлетворят любого пользователя
CAM-систем, а возможности его конфигурирования и пользовательский
интерфейс ориентированы на пользователя, не имеющего опыта
программирования. Чтобы эффективно работать с программой, пользователь
должен иметь некоторый опыт в разработке технологии получения изделий с
помощью станков с ЧПУ. EdgeCAM работает с пятиосным фрезерованием
для черновой и чистовой обработки, пакет моделирует выполнение
двухосной, соосной и радиальной, четырехосной токарной обработки, а
также двух- и четырехосную обработку заготовок на электроэрозионных
станках.
В этом методическом пособии будет показана последовательность
построения контура детали, а также будут рассмотрены возможности
создания технологии изготовления тел вращения и призматических деталей и
возможность установки нулевой точки детали в любую точку модели изделия
в CAD/CAM системе EdgeCAM, всё это позволит обеспечить качество и
производительность при создании УП.
В результате изучения материалов этого пособия, обучающиеся колледжа,
приобретут навыки работы с CAD/CAM системой EdgeCAM в создании
которой участвовали сообщество ведущих мировых компаний Pathtrace
(Великобритания) -Planit (Великобритания) -Vero Software (Великобритания)
–HEXAGON (Швеция).
5
1. Работа с осями координат в CAD/CAM системе
Создание осей

Выбираем постпроцессор fanucab.mcp

Выбираем инструмент

Нажимаем на пиктограмму «Index Operation»
В появившемся окне в строке «Name» выбираем созданную систему
координат

Выбираем цикл обработки
Отмечаем левой клавишей мыши геометрический элемент (поверхность),
которую необходимо обработать.
Для того, создать систему координат (CPL) необходимо в начале в режиме

«Switch to Design Mode».

Нажать на пиктограмму левой клавишей мыши «CPL from Face».

Появится окно «CPL».
В строке «Name» прежде чем ввести имя оси координат, убрать флажок с
режима «Origin»
В строке «Plane» выбирать геометрический элемент, относительно которого
система координат будет находится.
Левой клавишей мыши отмечаем этот геометрический элемент и нажимает
Enter.
Выбор созданных осей

В режиме «Switch to Design Mode».

Выбираем вкладку «Geometry», в появившемся меню выбираем «Select CPL».

Появится окно «CPL».
В строке «Name» выбираем имя оси координат.
6
Редактирование осей координат

В режиме «Switch to Design Mode».

Выбираем вкладку «Edit», в появившемся меню выбираем «CPL»

В меню «CPL» выбираем вкладку «General» в строке «CPL» выбираем
нужную ось.

Во вкладке «Reference» в строке «CPL» выбираем нужную ось.

Во вкладке «Rotate» поворачиваем ось, если это необходимо.
В строках «Х Rotation», «Y Rotation», «Z Rotation» указываем необходимый
угол.
Использование осей при обработке поверхностей.
В режиме «Switch to Manufacture Mode»

Выбираем инструмент

Нажимаем на пиктограмму «Index Operation»
В появившемся окне в строке «Name» выбираем созданную систему
координат

Выбираем цикл обработки
Отмечаем левой клавишей мыши геометрический элемент (поверхность),
которую необходимо обработать.
7
2. Проектирование контуров изделий в CAD/CAM системе
Войдите в режим Мanufacture (обработать) нажатием на пиктограмму
Manufacture, пиктограмма Design (спроектировать) автоматически
деактивизируется. Некоторые пиктограммы становятся неактивными в
режиме Мanufacture, другие наоборот не работают в режиме Design.
Далее необходимо заполнить диалоговое окно, изображенное ниже:
Discipline (Тип обработки): Выберите тип обработки – фрезерная, токарная,
электроискровая или реинжиниринг (использовать для работы с данными
координатно-измерительных машин).
Initial CPL (Рабочая плоскость): Вначале инструмент позиционируется
путем выравнивания оси инструмента относительно CPL.
Datum Type (Тип данных): Выберите тип выходных данных Absolute (в
абсолютных единицах) или Incremental (в приращения).
Machine Tool (Станок): Здесь происходит выбор постпроцессора. Команды
на обработку детали будут с применением выбранного
8
постпроцессора конвертироваться в инструкции для конкретного
ЧПУ - Fanuc; GE , Heidenhain и.т.д.
Machine Datum: Здесь может быть указана вторая база (точка смена
инструмента), например положение инструмента после отвода
(G53). Необязательный элемент данных.
Job Name (Имя задания): В данном поле вводится имя задания. Для каждой
детали может быть образовано свое имя и другие данные.
Sequence Name (Название технологической операции). В данном поле
вводится название технологической операции или её описание.
Design Entities (Примитивы)
После ознакомления с компоновкой EdgeCAM можно приступить к
разработке модели.
Очень важно то, что любую модель можно разложить на три элемента
(или ПРИМИТИВА в терминологии EdgeCAM).
Такими примитивами являются : - LINES (Отрезки); ARCS (Дуги) и
POINTS (Точки)
Перед разработкой любой модели мы должны определить цвет,
плоскость, слой и стиль примитивов.
Definitions (Определение):
Colour (Цвет) Примитивы могут иметь любой из тридцати двух цветов.
Style (Стиль) EdgeCAM предлагает 4 стиля линии: Solid (сплошная),
Dotted (пунктирная), Dashed (штриховая) или Chain (штрих-пунктирная)
Plane (Плоскость) EdgeCAM предлагает 6 стандартных проектных
плоскостей (в EdgeCAM их принято называть CPL - Конструкционная
плоскости). В черчении они эквивалентны видам.
Layer (Слой) Примитивы могут образовываться на любом из 256 слоев
(нумеруются с 0 до 255). Слои можно рассматривать как прозрачные пленки,
расположенные одна над другой и имеющие свое индивидуальное название
( Цвет )
(Стиль )
(до 64 символов)
( Слой )
(ПСК)
(Уровень )
9
Ввод координат с помощью мыши
После выбора команды Line Arc или Point, ввода параметров и щелчка
кнопки OK запрашивается положение примитива.
EdgeCAM предлагает многочисленные методы для описания положения, но
наиболее стандартным способом является использование мыши.
Наблюдая за перемещением курсора относительно, обратите внимание на
изменение формы курсора. Форма курсора будет зависеть от
разрешенного типа выбора: Разрешается только свободный выбор координат
Разрешается только выбор примитивов
Допускается любой способ (комбинация из двух
вышеперечисленных)
Свободный выбор координат определяется как текущее положение курсора
на экране.
Выбор примитивов интерпретируется как выбор объектов – линия, дуга,
точка, поверхность, группа и.т.д.
Также положение курсора может выбираться по GRID (Сетка).
Сетка отображается на экране активизацией команды Grid (меню View). В
процессе выбора координат можно привязываться к узлам сетки (если курсор
расположен близко от узла), необходимо активизировать привязку к узлам,
выбрав Grid на панели Input Options.
Задание точных координат
Выбор этой кнопки вызывает на экран диалоговое окно для ввода
координат. Если выбраны Декартовы координаты и активен ввод ZX, то вид
диалогового окна аналогичен приведенному ниже изображению:
Ввод координат
Введите необходимые координаты в поля X, Y, Z. Могут вводиться и
математические выражения, включающие знаки операций + - * /. Также
могут применяться скобки, задающие порядок операций.
Если координата не введена, то берется предыдущее значение. При
отсутствии предыдущего значения принимается значение 0.0.
Координаты геометрических элементов задаются относительно
выбранной системы координат.
10
Absolute-абсолютная система координат
Incremental –относительная система координат
После выбора опции Incremental (Приращения) обозначения полей ввода
X, Y or Z заменяются соответственно на IX, IY, IZ. Значения в поле
Command, также будут соответственно IX, IY или IZ. Образование отрезков
Отрезок
Вертикальный
Горизонтальный
Диалоговое окно
для отрезка
Полилиния
Coordinate input (ввод координат)
-polyline (полилиния)
11
CPL (CPL - Конструкционная плоскость) определяет начало координат.
Выберите кнопки OK или Continue, когда задание координат закончено
Удаление примитивов
В предыдущих упражнениях Вы образовывали примитивы, в этом мы
изучает как их удалить. Процесс удаления затрагивает 5 команд EdgeCAM.
Отмена
командыы
Прекращение выполнения команды
Удалить
Повторение
После выбора пиктограммы DELETE
(Удалить) EdgeCAM запросит, какие
команды
примитивы должны быть удалены. Далее Пользователь указывает каждый
удаляемый примитив. В случае большого количества удаляемых примитивов
можно их выбрать с помощью команды Window (Рамка) или Chain (Цепь
примитивов).
Zoom Extents – вписать рисунок
Zoom In - увеличить изображение
Zomm Out - уменьшить изображение
Zoom Window - зуммировать изображение в рамке выбора на весь видеопорт
Сохранение и открытие файлов в EdgeCАМ
Для сохранения текущего рисунка просто нажмите пиктограмму SAVE
или пункт FILE (Файл) в Горизонтальном меню и затем SAVE.
(Начать
новый сеанс)
(Открыть файл
(Сохранить файл)
12
Образование дуг
Существует два основных правила, которые надо знать, чтобы образовать
окружности/дуги в EdgeCAM.
a). Дуговый примитив всегда строится против часовой стрелки.
б). Начальная и конечная точка окружности всегда имеют угловое
положение 0/360 градусов.
с). Дуги/окружности, моделирующие сверление или нарезку резьбы,
должны иметь центральную точку.
Команда ARC требует ввести три точки,
лежащие на дуге. Команда RADIUS ARC
запрашивает начальный и конечный угол дуги, а
также величину радиуса.
Диалоговое окно ARC содержит все варианты
Диалоговое окно ARC содержит все варианты образования дуги.
Редактирование геометрических примитивов
Размещенные на экране примитивы можно затем редактировать. Можно
менять как атрибуты примитивов (цвет, слой и.т.д.), так и физический размер
13
примитива (длину, начало и.т.д.). Путем редактирования можно добавить
дополнительные примитивы.
Все вышесказанное реализуется командами редактирования.
Скругление
Фаска
Обрезать
обе
Редактировать все
Обрезать первый
Команда EDIT ALL
изменяет параметры выбранных примитивов с помощью диалогового окна.
В падающем меню Edit в Вы найдете следующие команды
редактирования:
Entity Data (параметры примитива) Individual (по отдельности) –
изменяет параметры выбранных примитивов по отдельности.
Entity Data (параметры примитива)  Match (согласовать) – Согласует
параметры набора выбранных примитивов с параметрами другого
примитива.
В процессе использования команды Edit All производится выбор
примитивов следующими способами: Window (выбор рамкой), Chain (выбор
цепочки примитивов) и Select Individually (индивидуальный выбор). Далее
предлагается диалоговое окно с редактируемыми параметрами.
Если выбрана дуга, то появится диалоговое окно следующего вида:
Если происходит выбор нескольких примитивов (например отрезков и
дуг), то диалоговое окно незначительно изменится. Оно будет содержать
только те параметры, которые являются общими для всех примитивов.
14
Используя команду EDIT INDIVIDUAL, Вы увидите увеличение
количества редактируемых параметров.
Если выбран отрезок, то диалоговое окно выглядит следующим образом:-
Иногда характеристики примитивов меняются в результате размещения
на его конце конструктивных элементов. Например, такими
конструктивными элементами могут быть сопрягающая дуга или фаска. В
обоих случаях возможно обрезание исходного примитива и, следовательно,
его изменение.
Вопросы
1 Перечислить типы обращений CAD модуля к пользователю.
2 Каковы требования к программному обеспечению САПР?
3 В чем заключается цель автоматизации проектирования?
15
3. Проектирование токарной обработки в CAD/CAM системе
Маршрутный технологический процесс изготовления вала
Номер
Наименование и содержание
Режущий инструмент
операции
Опера Пере
ции
хода
010
Токарная с ЧПУ
Проходной упорный резец для
1
Точить предварительно контур предварительного точения
вала
2
Точить окончательно контур
Проходной упорный резец для
вала
окончательного точения
3
Точить канавку
Канавочный резец
4
Нарезать резьбу
Резьбовой резец
Последовательность задания исходных данных для обработки контура вала
Войдите в режим «Switch to Manufacture Mode» (включить режим обработки)
нажатием
на пиктограмму
, пиктограмма «Switch to Design Mode»
(включить режим проектирования) автоматически деактивизируется.
Некоторые пиктограммы становятся неактивными в режиме «Switch to
Manufacture Mode», другие наоборот не работают в режиме «Switch to Design
Mode». Затем необходимо заполнить диалоговое окно, изображенное ниже:
16
Discipline (Тип обработки): Выберите тип обработки – фрезерная, токарная,
электроискровая или реинжиниринг (использовать для работы с
данными координатно-измерительных машин).
Initial CPL (Рабочая плоскость): Вначале инструмент позиционируется
путем выравнивания оси инструмента относительно CPL.
Datum Type (Тип данных): Выберите тип выходных данных Absolute (в
абсолютных единицах) или Incremental (в приращения).
Machine Tool (Станок): Здесь происходит выбор постпроцессора. Команды
на обработку детали будут с применением выбранного
постпроцессора конвертироваться в инструкции для конкретного
ЧПУ - Fanuc; GE , Heidenhain и.т.д.
Machine Datum: Здесь может быть указана вторая база (точка смена
инструмента), например положение инструмента после отвода
(G53). Необязательный элемент данных.
Job Name (Имя задания): В данном поле вводится имя задания. Для каждой
детали может быть образовано свое имя и другие данные.
Sequence Name (Название технологической операции). В данном поле
вводится название технологической операции или её описание.
После ввода описанная выше информация не редактируется.
Исключением являются некоторые данные о станке, которые могут
вводиться через команды M-functions и M/c Parameters.
17
Такие элементы данных как HOME; TOOL CHANGE (смена инструмента)
задают значения координат X и Z. Их значения определены в
постпроцессоре.
После этого прорисовываем контур детали в режиме
Design Mode»
Switch to
Записываем файл под именем Val
Затем переходим в режим «Switch to Manufacture Mode»
Нажимаем пиктограмму (инструментальный магазин) «Tool Store» появляется меню,
в котором выбираем режущий инструмент PCLNL-2525 и нажимаем Select
Нажимаем пиктограмму (цикл предварительного точения) – «Rough Turn»
появляется меню, в котором указываем припуск на окончательное точение
После этого в правом углу экрана появятся сообщения:
18
1) Line/Arc/Continuous/Group as profile
Отмечаем контур вала и нажимаем Enter
2) Digitise start/end point to alter
Нажимаем Enter
3) Digitise Billet or cycle start position
Вводим координаты начальной точки цикла и нажимаем Enter
Затем отводим инструмент, нажимая пиктограмму
(отвод инструмента для смены)
- «Toolchange»
Нажимаем пиктограмму (инструментальный магазин) «Tool Store» появляется меню, в котором выбираем PDJNR-2525 и нажимаем Select
-
появляется меню, нажимаем ОК
Нажимаем пиктограмму (окончательная обработка) «Finish Turn
После этого в правом углу экрана появятся сообщения:
1) Line/Arc/Continuous/Group as profile
Отмечаем контур вала и нажимаем Enter
2) Digitise new start point for profile chain (or Finish)
Отмечаем точку начала обработки и нажимаем Enter
3) Digitise start/end point to alter
Нажимаем Enter
Затем отводим инструмент, нажимая пиктограмму
-Toolchange
Нажимаем пиктограмму (инструментальный магазин) «Tool Store» появляется меню, в котором выбираем канавочный резец MBS5-151
нажимаем Select
Нажимаем пиктограмму (окончательная обработка канавки) «Finish Groove»
появляется меню, нажимаем ОК
После этого в правом углу экрана появятся сообщения:
19
1) Line/Arc/Continuous/Group as profile
Отмечаем левую линию канавки, нажимаем Enter
2) Digitise new start point for profile chain (or Finish)
Нажимаем Enter
3) Digitise start/end point to alter
Нажимаем Enter
Затем отводим инструмент, нажимая пиктограмму
-Toolchange
Нажимаем пиктограмму (инструментальный магазин) «Tool Store» появляется меню, в котором выбираем резьбовой резец R166.4 нажимаем
Select
Нажимаем пиктограмму (нарезание резьбы) «Thread» меню, задаем
появляется
значение резьбы во вкладке «General» в строке «Lead (Pitch^Starts)» - шаг
резьбы, во вкладке «Depth» в строках: «Total Depth» - глубина резьбы, «Cut
Increment» - 0.2 - глубина резания одного рабочего хода, затем регулируем
врезание режущего инструмента «Lead In»-3 и перебег режущего
инструмента «Lead Out»-1 и нажимаем ОК
После этого в правом углу экрана появятся сообщения:
1) Digitise drive line
Отмечаем линию резьбы, нажимаем Enter
Отводим инструмент в инструментальный магазин, нажимая пиктограмму
«Home»
При окончании ввода данных осуществляем проверку ввода данных с
помощью симулятора, в случае обнаружения ошибок отредактировать
исходные данные.
С помощью режима Generate Codeпрограмму
получаем управляющую
20
Вопросы
1. Что позволяет делать режим «Switch to Manufacture?
2. Что осуществляет режим «Simulate Machining»?
3. Что представляет собой стратегия «Rough Turn»?
21
4. Проектирование сверлильной и фрезерной обработки в CAD/CAM
системе
Маршрут изготовления поверхностей модели плиты
Таблица №1
Номер
Наименование и содержание
Режущий инструмент
Опера- Переоперации
ции
хода
010
1-6
7
8-9
1012
13
14
15
Программная
Сверление 6 центровочных
отверстий, глубина резания
по оси Z=5 мм
Сверление 1 отверстия Ø30
Сверление 2 отверстий Ø10
Сверление 3 отверстий Ø6
Предварительное
фрезерование внутреннего
профиля, глубина резания по
оси Z=2 мм
Окончательное фрезерование
внешнего профиля, глубина
резания по оси Z=2 мм
Окончательное фрезерование
внешнего контура, глубина
резания по оси Z=5 мм
Центровое сверло Ø3,15 мм
Сверло диаметром Ø30 мм
Сверло диаметром Ø10 мм
Сверло диаметром Ø 6 мм
Концевая фреза Ø25 мм
Концевая фреза Ø30 мм
Концевая фреза Ø30 мм
22
1) Запустить программу EdgeCAM
2) Разработанную модель плиты в программе SolidWorks транслируем в
программу EdgeCAM
 Из меню File выберите команду Open или пиктограмму на
стандартной инструментальной панели.
 Необходимо найти файл, который находится
d:\Инженер\SolidWorks\имя файла
3) Сохранить файл
 Из меню File выберите команду Save или пиктограмму на
стандартной инструментальной панели.
 Указать путь d:\Инженер\EdgeCAM\имя файла
4) В программе EdgeCAM разбиваем модель плиты на поверхности
Для этого в режиме
проектирования)
«Switch to Design Mode» (включить режим
 Создаем новый слой, для этого правой клавишей «мыши» щелкаем в
меню «Layers», после чего появится падающее меню, в котором
выбираем команду «New», после этого в окне «Name» команды «Layers
Properties» вводим имя слоя «Hole»-отверстие и нажимаем клавишу
OK.
23
 Затем левой клавишей мыши входим в меню «Solids», в котором
находим команду «Geometry», на экране появится меню команды,
нажимаем клавишу OK.
Внизу экрана появится строка сообщения: «Select an edge to create a line, arc
or continuous» (Выберите элемент, чтобы создать линию, дугу или
непрерывный контур), отмечаем левой клавишей мыши 6 отверстий и
нажимаем Enter.
Таким образом, все наши отверстия будут находиться на одном слое.
 Аналогично создаем и отмечаем внутренний и внешний профиль
плиты, меняя при этом только названия. Для внутреннего профиля
выберем название – «PR1», для внешнего– «PR2».
 После этого, все наши элементы будут находиться на своем слое.
 В связи с тем, что вначале технологического процесса будем
изготавливать отверстия, все остальные элементы сделаем невидимыми
с помощью меню «Layers», в котором двойным щелчком мыши
изменим команду «Yes» на команду «No», после этого на экране
останутся только отверстия.
24
5) Войдите в режим «Switch to Manufacture Mode»
(включить режим обработки) нажатием
на пиктограмму
, пиктограмма «Switch to Design Mode»
(включить режим проектирования) автоматически деактивизируется.
Некоторые пиктограммы становятся неактивными в режиме «Switch to
Manufacture Mode», другие наоборот не работают в режиме «Switch to Design
Mode»
Далее необходимо заполнить диалоговое окно, изображенное ниже:
25
Discipline (Тип обработки): Выберите тип обработки – фрезерная, токарная,
электроискровая или реинжиниринг (использовать для работы с
данными координатно-измерительных машин).
Initial CPL (Рабочая плоскость): Вначале инструмент позиционируется
путем выравнивания оси инструмента относительно CPL.
Datum Type (Тип данных): Выберите тип выходных данных Absolute (в
абсолютных единицах) или Incremental (в приращения).
Machine Tool (Станок): Здесь происходит выбор постпроцессора. Команды
на обработку детали будут с применением выбранного
постпроцессора конвертироваться в инструкции для конкретного
ЧПУ - Fanuc; GE , Heidenhain и.т.д.
Machine Datum: Здесь может быть указана вторая база (точка смена
инструмента), например положение инструмента после отвода
(G53). Необязательный элемент данных.
Job Name (Имя задания): В данном поле вводится имя задания. Для каждой
детали может быть образовано свое имя и другие данные.
Sequence Name (Название технологической операции). В данном поле
вводится название технологической операции или её описание.
Lathe Setup (Установка параметров токарного станка). В данном поле
вводится параметры двух шпиндельного токарно-фрезерного станка.
Затем нажать клавишу ОК.
После ввода описанная выше информация не редактируется.
Исключением являются некоторые данные о станке, которые могут
вводиться через команды M-functions и M/c Parameters, а также с
помощью дерева проектирования технологического процесса, щелкнув
правой клавишей мыши по команде Sequence (технологический процесс) и
выбрать в меню команду Edit (редактировать) левой клавишей мыши.
Затем в графе «Units» (измерения) появившегося меню выбрать
Millimetres.
26
Такие элементы данных как HOME; TOOL CHANGE (смена инструмента) и
INITIAL PLANE задают значения координат X Y и Z. Их значения
определены в постпроцессоре.
Сверление 6 центровых отверстий Ø3,15
Нажимаем пиктограмму (инструментальный магазин) «Tool Store» появляется меню,
27
в котором выбираем режущий инструмент 3mm x 60 Centredrill – 13A F30M
и нажимаем Select.
После выбора пиктограммы
появится меню
«New Hole» (новое отверстие)
Используя закладку General (Общая), в графе Plunge Feed (mm/min)(плунжерная подача)
ввести 120, в графе Speed (RPM)-(частота вращение шпинделя) ввести 10000.
Используя закладку Depth (глубина), в графе Clearance (плоскость
безопасности) ввести 25,
в графе Level (уровень) ввести 20, а в графе Depth -5 и нажать OK.
Внизу экрана появится строка сообщения: «Digitise location for hole centre»-(
переведите в цифровую местоположение центра отверстия).
Выберем положение центров отверстий, с помощью левой клавиши мыши и
нажмем Enter.
Затем отводим инструмент, нажимая пиктограмму
-Toolchange
28
Сверление 1 отверстия Ø30
Затем выбираем пиктограмму (инструментальный магазин)
Store» - появляется меню,
«Tool
в котором выбираем режущий инструмент Coromant 30mm и нажимаем
Select.
После выбора пиктограммы
меню.
«New Hole» (новое отверстие) появится
Используя закладку General (Общая), в графе Plunge Feed (mm/min)(плунжерная подача)
ввести 70, в графе Speed (RPM)-(частота вращение шпинделя) ввести 1000.
Используя закладку Depth (глубина), в графе Clearance (плоскость
безопасности) ввести 25,
в графе Level (уровень) ввести 20, а в графе Depth -30 и нажать OK.
29
Внизу экрана появится строка сообщения: «Digitise location for hole centre»(укажите местоположение центра отверстия).
Выберем положение центра отверстия, с помощью левой клавиши мыши и нажмем
Enter.
Сверление 2 отверстий Ø10
Выбираем пиктограмму (инструментальный магазин) «Tool Store» появляется меню, в котором выбираем режущий инструмент Coromant 10mm
и нажимаем Select.
После выбора пиктограммы
меню
«New Hole» (новое отверстие) появится
Используя закладку General (Общая), в графе Plunge Feed (mm/min)(плунжерная подача)
ввести 90, в графе Speed (RPM)-(частота вращение шпинделя) ввести 2000.
Используя закладку Depth (глубина), в графе Clearance (плоскость
безопасности) ввести 25, в графе Level (уровень) ввести 20, а в графе Depth 28 и нажать OK.
Внизу экрана появится строка сообщения: «Digitise location for hole centre»-(
переведите в цифровую местоположение центра отверстия).
Выберем положение центров отверстий, с помощью левой клавиши мыши и
нажмем Enter.
Затем отводим инструмент, нажимая пиктограмму
-Toolchange
Сверление 3 отверстий Ø6
Затем выбираем пиктограмму (инструментальный магазин)
Store»,
«Tool
30
появляется меню, в котором выбираем режущий инструмент Coromant
6mm и нажимаем Select.
После выбора пиктограммы
меню
«New Hole» (новое отверстие) появится
Используя закладку General (Общая), в графе Plunge Feed (mm/min)(плунжерная подача) ввести 110, в графе Speed (RPM)-(частота вращение
шпинделя) ввести 4000.
Используя закладку Depth (глубина), в графе Clearance (плоскость
безопасности) ввести 25, в графе Level (уровень) ввести 20, а в графе Depth 27 и нажать OK.
Внизу экрана появится строка сообщения: «Digitise location for hole centre»(переведите в цифровую форму местоположение центра отверстия).
Выберем положение центров отверстий, с помощью левой клавиши мыши и
нажмем Enter.
Предварительное фрезерование внутреннего профиля
В связи с тем, что согласно технологического процесса будем изготавливать
внутренний профиль, все остальные элементы сделаем невидимыми с
помощью меню «Layers», в котором двойным щелчком мыши изменим
команду «Yes» на команду «No», после этого на экране останется только
внутренний профиль
Выбираем пиктограмму
- Roughing Operation «предварительное
фрезерование внутреннего профиля»
Внизу экрана появится строка сообщения: «Digitise Geometry to machine»
(переведите в цифровую форму геометрию на машину)
Выберем положение внутреннего профиля, с помощью левой клавиши мыши
и нажмем Enter.
Внизу экрана появится строка сообщения: «Select boundary entities (Finish for
none)» (Выберите границы объекта) нажмем Enter.
На экране появится меню «Roughing Operation»
31
Используя закладку General (Общая), в графе Offset-(припуск) ввести 1.
Используя закладку Tooling (инструменты), нажать клавишу «Find» (найти)
появится меню «Tool Store» (инструментального магазина), в котором
32
необходимо выбрать инструмент «30mm EndMill»- концевую фрезу Ø30,
нажать Select, в графе Position (позиция) указать 5, а затем нажать ОК.
Используя закладку Depth (глубина), в графе Clearance (плоскость
безопасности) ввести 25,в графе Level (уровень) ввести 20, в графе Depth -9,
а в графе Cut Increment (Глубина резания одного рабочего хода) ввести 5 и
нажать OK.
Затем отводим инструмент, нажимая пиктограмму
-Toolchange
Окончательное фрезерование внутреннего профиля
Выбираем пиктограмму
- Roughing Operation «предварительное
фрезерование внутреннего профиля»
Внизу экрана появится строка сообщения: «Digitise Geometry to machine»
(переведите в цифровую форму геометрию на машину)
Выберем положение внутреннего профиля, с помощью левой клавиши мыши
и нажмем Enter.
33
Внизу экрана появится строка сообщения: «Select boundary entities (Finish for
none)» (Выберите границы объекта) нажмем Enter.
На экране появится меню «Roughing Operation»
Используя закладку General (Общая), в графе Offset-(припуск) ввести 0.
Используя закладку Tooling (инструменты), нажать клавишу «Find» (найти)
появится меню «Tool Store» (инструментального магазина), в котором
необходимо выбрать инструмент
«30mm EndMill»- концевую фрезу Ø30, нажать Select, в графе Position
(позиция) указать 6, а затем нажать ОК.
Используя закладку Depth (глубина), в графе Clearance (плоскость
безопасности) ввести 25,
в графе Level (уровень) ввести 20, в графе Depth -10, а в графе Cut Increment
(Глубина резания одного рабочего хода) ввести 5 и нажать OK.
Затем отводим инструмент, нажимая пиктограмму
-Toolchange
Окончательное фрезерование внешнего контура
В связи с тем, что согласно технологического процесса, будем изготавливать
наружный профиль, все остальные элементы сделаем невидимыми с
помощью меню «Layers», в котором двойным щелчком мыши изменим
команду «Yes» на команду «No», после этого на экране останется только
наружный профиль.
Выбираем пиктограмму
наружного профиля)
- «Profiling Operation» (фрезерование
Внизу экрана появится строка сообщения: «Digitise Profile(s)» (переведите в
цифровую форму профиль или профили)
Выберем положение наружного профиля, с помощью левой клавиши мыши и
нажмем Enter.
Внизу экрана появится строка сообщения: «Digitise new start points for profile
chain (of Finish)» Переведите в цифровую форму новые точки начала для
цепи профиля (Конца)
34
Отмечаем левой клавишей мыши точку начала наружного профиля нажмем
Enter.
Внизу экрана появится строка сообщения: «Select boundary entities (Finish for
none)» (Выберите границы объекта) нажмем Enter.
На экране появится меню «Profiling Operation»
35
Используя закладку General (Общая), в графе Mill Type - (тип фрезерования)
выбрать Optimised (оптимальный).
Используя закладку Tooling (инструменты), нажать клавишу «Find» (найти)
появится меню «Tool Store» (инструментального магазина), в котором
необходимо выбрать инструмент
«30mm EndMill»- концевую фрезу Ø30, нажать Select, в графе Position
(позиция) указать 7, а затем нажать ОК.
36
Используя закладку Depth (глубина), в графе Clearance (плоскость
безопасности) ввести 25,
в графе Level (уровень) ввести 20, в графе Depth -25, а в графе Cut Increment
(Глубина резания одного рабочего хода) ввести 5 и нажать OK.
Отводим инструмент в инструментальный магазин, нажимая пиктограмму
«Home»
При окончании ввода данных осуществляем проверку ввода данных с
помощью симулятора, в случае обнаружения ошибок отредактировать
исходные данные.
С помощью режима «Generate Code» программу
получаем управляющую
Вопросы
1 Стратегии обработки в CAD/CAM системе.
2 Каковы требования к программному обеспечению CAD/CAM системы?
37
5. Проектирование электроэрозионной обработки в CAD/CAM системе
Маршрутный технологический процесс изготовления контура детали
Номер
Наименование и содержание
Режущий инструмент
Опера- Переоперации
ции
хода
010
1
Электроэрозионная
Вырезать контур детали
Войдите в режим «Switch to Manufacture Mode»
Проволочный электродинструмент
(включить режим
обработки) нажатием на пиктограмму, пиктограмма «Switch to Design Mode»
автоматически
деактивизируется на пиктограмму
. Некоторые пиктограммы становятся
неактивными в режиме «Switch to Manufacture Mode», другие наоборот не
работают в режиме «Switch to Design Mode»
Далее необходимо заполнить диалоговое окно, изображенное ниже:
Discipline (Тип обработки): Выберите тип обработки – фрезерная, токарная,
электроискровая или реинжиниринг (использовать для работы с
данными координатно-измерительных машин).
Initial CPL (Рабочая плоскость): Вначале инструмент позиционируется
путем выравнивания оси инструмента относительно CPL.
Datum Type (Тип данных): Выберите тип выходных данных Absolute (в
абсолютных единицах) или Incremental (в приращения).
38
Machine Tool (Станок): Здесь происходит выбор постпроцессора. Команды
на обработку детали будут с применением выбранного
постпроцессора конвертироваться в инструкции для конкретного
ЧПУ - Fanuc; GE , Heidenhain и.т.д.
Machine Datum: Здесь может быть указана вторая база (точка смена
инструмента), например положение инструмента после отвода
(G53). Необязательный элемент данных.
Job Name (Имя задания): В данном поле вводится имя задания. Для каждой
детали может быть образовано свое имя и другие данные.
Sequence Name (Название технологической операции). В данном поле
вводится название технологической операции или её описание.
После ввода описанная выше информация не редактируется.
Исключением являются некоторые данные о станке, которые могут
вводиться через команды M-functions и M/c Parameters.
Задание инструмента для вырезания контура электрод-инструментом :
для выбора электрод-инструмента нужно выбрать команду Cycles, a затем
Select Wire. Определив соответствующие параметры, нажмите OK.
39
Цикл вырезания профиля (2D Profile)
Цикл вырезания электрод-инструментом профиля (контура) представляет
собой движение ЭИ по двухплоскостной траектории. Для выбора цикла
нужно выбрать команду Cycles, a затем 2D Profile. Определив
соответствующие параметры, нажмите OK.
После этого в правом углу экрана появится сообщения:
1) Line/Arc/Continuous/Group as profile
Отмечаем контур и нажимаем Enter
2) Digitise new start point for profile chain (or Finish)
Отмечаем точку начала обработки и нажимаем Enter
3) Digitise start/end point to alter
Нажимаем Enter
При окончании ввода данных осуществляем проверку ввода данных с
помощью симулятора, в случае обнаружения ошибок отредактировать
исходные данные.
С помощью режима Generate Codeпрограмму
получаем управляющую
Вопросы
1 Особенности стратегий технологии изготовления поверхностей при
электроэрозионной обработке.
2 Сущность электроэрозионной обработки
40
Литература
1. Серебреницкий П.П. Программирование для автоматизированного
оборудования: Учебник для сред. проф. учебных заведений [Текст] / П.П.
Серебреницкий, А.Г.Схиртладзе; Под ред. Ю.М. Соломенцева.- М.: Высш.
шк., 2003.-592с.
2. EdgeCAM Version 12 [Текст] Pathtrace Engineering Systems -2007-345c.
41
Приложения
Ra 6,3 ( )
G
0,01
A
A
H
2x45 
3 фаски
D
E
Ra 1,6
I
J
K
Рис.1. Эскиз детали вал
F
Ra 1,6
C
B
A
Ra 1,6
2
42
Варианты заданий
№
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
А
63h12
54h12
55h12
56h12
57h12
58h12
59h12
61h12
62h12
63h12
64h12
65h12
66h12
67h12
68h12
69h12
70h12
71h12
72h12
53h12
52h12
51h12
50h12
49h12
48h12
46h12
47h12
48h12
49h12
50h12
B
48h7
49h7
50h7
51h7
52h7
53h7
54h7
56h7
57h7
58h7
59h7
60h7
61h7
62h7
63h7
64h7
65h7
66h7
67h7
47h7
46h7
45h7
44h7
43h7
42h7
40h7
41h7
42h7
42h7
43h7
C
43h7
44h7
45h7
46h7
47h7
48h7
49h7
51h7
52h7
53h7
54h7
55h7
56h7
57h7
58h7
59h7
59h7
60h7
61h7
40h7
39h7
38h7
37h7
35h7
34h7
33h7
34h7
35h7
36h7
37h7
D
38h7
39h7
40h7
41h7
42h7
43h7
44h7
46h7
47h7
48h7
49h7
50h7
51h7
52h7
53h7
54h7
54h7
55h7
56h7
36h7
35h7
34h7
33h7
32h7
31h7
29h7
30h7
31h7
32h7
33h7
E
21-0,2
22-0,2
23-0,2
24-0,2
25-0,2
26-0,2
27-0,2
29-0,2
30-0,2
31-0,2
32-0,2
33-0,2
34-0,2
35-0,2
36-0,2
37-0,2
38-0,2
39-0,2
40-0,2
20-0,1
19-0,1
18-0,1
18-0,1
17-0,1
16-0,1
14-0,1
15-0,1
16-0,1
17-0,1
18-0,1
Таблица 1
F
M251,5-8g
M261,5-8g
M271,5-8g
M281,5-8g
M291,5-8g
M302,5-8g
M313,5-8g
M334,5-8g
M343,5-8g
M352,5-8g
M363,5-8g
M374,5-8g
M383-8g
M392-8g
M404,5-8g
M411,5-8g
M421,5-8g
M431,5-8g
M441,5-8g
M241-8g
M230,8-8g
M220,8-8g
M211-8g
M201-8g
M191-8g
M170,8-8g
M180,9-8g
M181-8g
M191,1-8g
M201,2-8g
G
83-0,2
84-0,2
85-0,2
86-0,2
87-0,2
88-0,2
89-0,2
91-0,2
92-0,2
93-0,2
94-0,2
95-0,2
96-0,2
97-0,2
98-0,2
99-0,2
100-0,2
101-0,2
102-0,2
81-0,2
80-0,2
79-0,2
78-0,2
77-0,2
76-0,2
74-0,2
75-0,2
76-0,2
77-0,2
78-0,2
H
38-0,2
39-0,2
40-0,2
41-0,2
42-0,2
43-0,2
44-0,2
46-0,2
47-0,2
48-0,2
49-0,2
50-0,2
51-0,2
52-0,2
53-0,2
54-0,2
55-0,2
56-0,2
57-0,2
36-0,2
35-0,2
34-0,2
33-0,2
32-0,2
31-0,2
29-0,2
30-0,2
31-0,2
32-0,2
33-0,2
I
133-0,2
134-0,2
135-0,2
136-0,2
137-0,2
138-0,2
139-0,2
141-0,2
152-0,2
143-0,2
144-0,2
145-0,2
146-0,2
147-0,2
148-0,2
149-0,2
150-0,2
151-0,2
152-0,2
132-0,2
131-0,2
130-0,2
129-0,2
128-0,2
127-0,2
125-0,2
126-0,2
127-0,2
128-0,2
129-0,2
J
163-0,3
164-0,3
165-0,3
166-0,3
167-0,3
168-0,3
169-0,3
171-0,3
172-0,3
173-0,3
174-0,3
175-0,3
176-0,3
177-0,3
178-0,3
179-0,3
180-0,3
181-0,3
182-0,3
160-0,3
159-0,3
158-0,3
157-0,3
156-0,3
155-0,3
153-0,3
154-0,3
156-0,3
157-0,3
158-0,3
K
193-0,4
194-0,4
195-0,4
196-0,4
197-0,4
198-0,4
199-0,4
201-0,4
202-0,4
203-0,4
204-0,4
205-0,4
206-0,4
207-0,4
208-0,4
209-0,4
210-0,4
211-0,4
212-0,4
190-0,4
189-0,4
188-0,4
188-0,4
187-0,4
186-0,4
184-0,4
185-0,4
186-0,4
187-0,4
188-0,4
43
Ra 6,3
B
A
120
O
63,5
K
120
L
A

M
J
P
C
A
D
E
F
A
A
Ra 3,2

30

6
10
20
G

10
2отв.
3отв.
Рис.2 Эскиз плиты
44
Варианты заданий
Таблица 2
№
A
B
C
D
E
P
F
J
K
L
M
O
G
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
1200,2
1190,2
1180,2
870,2
910,2
920,2
900,2
890,2
880,2
870,2
910,2
920,2
900,2
890,2
880,2
870,2
910,2
920,2
930,2
940,2
950,2
960,2
970,2
980,2
990,2
1000,2
980,2
1100,2
1110,2
1120,2
15
14
13
18
16
17
15
14
14
12
16
17
15
14
13
18
16
17
18
19
15
14
13
18
14
16
16
13
18
15
101
102
103
104
105
106
107
108
102
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
115
116
117
118
119
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
160
161
162
163
164
165
174
163
164
165
166
141
142
143
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
215
216
217
218
219
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
80
81
82
83
84
85
90
89
88
87
86
341
342
343
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
416
430
429
431
428
140
141
142
143
139
138
140
141
142
143
139
138
140
141
142
143
139
138
139
140
138
141
139
140
141
141
144
139
135
133
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
100
120
111
112
113
41
42
43
44
45
46
47
48
49
50
31
32
53
54
45
46
37
38
39
40
41
42
33
44
35
25
26
27
28
29
80
81
82
83
79
78
80
81
82
83
79
78
80
81
82
83
79
78
77
76
75
74
73
72
71
79
78
77
76
75
90
91
92
113
109
108
110
111
112
113
109
108
110
111
112
113
109
108
107
106
105
104
103
102
101
120
119
117
115
113
1210,05
1220,05
1230,05
1240,05
1250,05
1260,05
1270,05
1280,05
1290,05
1300,05
1310,05
1320,05
1330,05
1340,05
1350,05
1360,05
1370,05
1380,05
1390,05
1400,05
1380,05
1410,05
1420,05
1390,05
1380,05
1200,05
1210,05
1230,05
1240,05
125 0,05
R0,5
R0,5
R0,5
R0,5
R0,5
R0,5
C
A
45
R0,5
B
R0,5
R0,5
F
R0,5
G
R0,5
R0,5
D
E
Рис.3 Эскиз контура детали
46
№
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
A
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
17
18
19
20
21
22
23
24
25
26
B
5.2
6.2
7.2
8.2
9.2
10.2
11.2
12.2
13.2
14.2
15.2
16.2
17.2
18.2
19.2
20.2
21.2
22.2
23.2
24.2
17.2
18.2
19.2
20.2
21.2
22.2
23.2
24.2
25.2
26.2
Варианты заданий
C
D
6.5
24
8.5
26
10.5
28
12.5
30
14.5
32
16.5
34
18.5
36
20.5
38
22.5
40
24.5
42
26.5
44
28.5
46
30.5
48
32.5
50
34.5
52
36.5
54
38.5
56
40.5
58
42.5
60
44.5
62
18.5
64
19.5
66
20.5
68
21.5
70
22.5
72
23.5
74
24.5
76
25.5
78
26.5
80
27.5
82
E
32
34
36
38
40
42
44
46
48
50
52
54
56
58
60
62
64
66
68
70
72
74
76
78
80
82
84
86
88
90
Таблица 3
F
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
G
6.5
7.5
8.5
9.5
10.5
11.5
12.5
13.5
14.5
15.5
16.5
17.5
18.5
19.5
20.5
21.5
22.5
23.5
24.5
25.5
26.5
27.5
28.5
29.5
30.5
31.5
32.5
33.5
34.5
35.5
Скачать