Загрузил Татьяна Аксенова

презентация

Реклама
Повторим:
1. Где наблюдаются повторяющиеся
процессы? Приведи примеры.
2. К какому типу относится алгоритм,
содержащий конструкцию
«повторение»?
3. Вспомни виды циклических
конструкций.
Повторим:
Цикл с заданным
условием
продолжения
работы
Цикл с заданным
условием
окончания
работы
Цикл с заданным
числом
повторений
Программирование
алгоритмической конструкции
«цикл»
while
repeat
for
Кутепова Н.В, МОАУ «СОШ №4 г.Соль- Илецка Оренбургской обл.»2017 г.
Цикл с заданным условием продолжения работы
Алгоритмический
язык
Язык Pascal
нц пока условие while условие do
тело цикла
begin
кц
тело цикла
end;
Выполнить алгоритм Паскаль и
протестировать программу для следующих
значений
Цикл с заданным условием окончания работы
Алгоритмический
язык
нц
тело цикла
кц при условие
Язык Pascal
repeat
тело цикла
until условие;
Выполнить алгоритм Паскаль и
протестировать программу для следующих
значений
Цикл с заданным числом повторений
Алгоритмический
язык
нц для X от 1
до 5
тело цикла
кц
Язык Pascal
for X:=знач. 1 to
begin
тело цикла
end;
знач.2
do
Выполнить
алгоритм Паскаль
и протестировать
программу
Скачать