алгоритмы на школьном алгоритмическом языке

Реклама
АЛГОРИТМИЧЕСКИЙ
ЯЗЫК
Презентация разработана учителем информатики
МБОУ СОШ 31 Осадчей Ириной Владимировной
Таблица основных условных обозначений
в блок-схемах
Условное
обозначение
Назначение блока
.
.
Базовая структура линейного алгоритма:
РАЗВЕТВЛЯЮЩИЕСЯ АЛГОРИТМЫ
да
нет
АЛГОРИТМЫ С ПОВТОРЕНИЕМ(ЦИКЛ)
нет
да
АЛГОРИТМЫ НА ШКОЛЬНОМ
АЛГОРИТМИЧЕСКОМ ЯЗЫКЕ
АЛГОРИТМИЧЕСКИЙ ЯЗЫК (АЯ) – это
текстовая форма
описания алгоритма.
СЛУЖЕБНЫЕ СЛОВА
алг (алгоритм) сим (символьный)
арг (аргумент) лит (литерный)
рез (результат) лог (логический)
нач (начало)
таб(таблица)
кон (конец)
нц (начало цикла)
цел (целый)
кц (конец цикла)
вещ (вещественный)
длин (длина)
дано для
от
нет
если
то знач
иначе
все
или
пока
да
до
при
выбор
ввод
вывод
не
Команды школьного АЯ
Команда присваивания.
Общий вид: А := В, где знак ":="
означает команду заменить прежнее
значение переменной, стоящей в левой части, на вычисленное значение
выражения, стоящего в правой части.
Например, a := (b+c) * sin(Pi/4); i := i+1.
Команды ввода и вывода.
ввод имена переменных
вывод имена переменных, выражения, тексты.
Команды если и выбор. Применяют для организации ветвлений.
Команды для и пока. Применяют для организации циклов.
Пример записи алгоритма на школьном АЯ
алг Сумма квадратов (арг цел n, рез цел S)
дано | n > 0
надо | S = 1*1 + 2*2 + 3*3 + ... + n*n
нач цел i
ввод n; S:=0
нц для i от 1 до n
S:=S+i*i
кц
вывод "S = ", S
кон
Базовая структура "следование". Образуется
последовательностью действий, следующих
одно за другим:
Школьный алгоритмический язык
Язык блок-схем
действие 1
действие 2
.........
действие n
Базовая структура "ветвление". Обеспечивает в
зависимости от результата проверки условия (да или нет) выбор
одного из альтернативных путей работы алгоритма. Каждый из
путей ведет к общему выходу, так что работа алгоритма будет
продолжаться независимо от того, какой путь будет выбран.
Структура ветвление существует в четырех основных вариантах:
если—то;
если—то—иначе;
Школьный алгоритмический язык
1. если—то
если условие
то
действие
все
2. если—то—иначе
если условие
то действия 1
иначе действия 2
все
Язык блок-схем
Примеры структуры ветвление
Школьный алгоритмический язык
если x > 0
то у := sin(x)
все
если a > b
то a := 2*a; b := 1
иначе b := 2*b
все
Язык блок-схем
Базовая структура "цикл". Обеспечивает многократное
выполнение некоторой совокупности действий, которая называется
телом цикла. Основные разновидности циклов представлены в
таблице:
Школьный алгоритмический язык
Язык блок-схем
Цикл типа пока.
Предписывает выполнять тело цикла до тех пор,
пока выполняется условие,
записанное после слова пока.
нц пока условие
тело цикла
(последовательность действий)
кц
Цикл типа для.
Предписывает выполнять тело цикла для всех значений
некоторой переменной (параметра цикла)
в заданном диапазоне.
нц для i от i1 до i2
тело цикла
(последовательность действий)
кц
Примеры структуры цикл
Школьный алгоритмический язык
блок-схем
нц пока i <= 5
S := S+A[i]
i := i+1
кц
нц для i от 1 до 5
X[i] := i*i*i
Y[i] := X[i]/2
кц
Язык
ПРАКТИЧЕСКАЯ РАБОТА.
Записать вычисление площади треугольник
•
с помощью АЯ
•
с помощью блок – схем.(В программе
«Конструктор Алгоритмов»
Переменные: h(высота),а(основание),s(площадь).
алг Площадь (арг цел h,арг цел а , рез вещ s)
нач
ввод h,a
s:=h*a/2
вывод s
кон
1.
РЕШЕНИЕ:
Переменные: h(высота),а(основание),s(площадь).
алг Площадь треугольника (арг цел h,арг цел а , рез вещ s)
нач
ввод h,a
s:=h*a/2
вывод s
кон
Домашнее задание:
1. параграф 32,33.
2.Составить алгоритм сложения двух
простых добей на АЯ .
Скачать