СервоМастер 2 - Сервотехника

Реклама
СервоМастер 2
Руководство пользователя
Программа «СервоМастер 2» предназначена для конфигурирования и наладки
СЧПУ «СервоКон» (далее СЧПУ). Программа позволяет:
- задавать конфигурацию подключения оборудования (приводы, концевые
выключатели, шпиндель и т. п.) к СЧПУ;
- настраивать значения параметров СЧПУ, в том числе в режиме он-лайн;
- производить анализ параметров работы СЧПУ с помощью программного
осциллографа.
Установка и запуск
Запустите программу установки и следуйте инструкциям. Для запуска программы
используйте ярлык на рабочем столе или в меню «Пуск» в разделе «Программы –
Сервотехника – СервоМастер 2».
Описания комплектаций
По мере добавления новых функций в СЧПУ на сайте компании будут
выкладываться обновленные описания комплектаций. Для обновления описания
комплектации скопируйте файл в директорию программы (по умолчанию <Program
Files>/Servotechnica/ServoMaster2). Пожалуйста, проверяйте появление обновлений для
вашей комплектации СЧПУ.
Создание конфигурации
В главном меню выберите Файл - Новый, в появившемся окне введите имя
конфигурации и выберите комплектацию СЧПУ, для которой создается конфигурация.
Внимание! Выбор неверного типа комплектации может привести к сбоям СЧПУ и
неработоспособности функций, заданных в конфигурации.
Открытие сохраненной конфигурации
В главном меню выберите «Файл» – «Открыть» и выберите нужный файл
конфигурации.
В случае если вы установили обновленное описание своей комплектации и
пытаетесь открыть конфигурацию, созданную для более старого описания комплектации,
то программа предложит выбор: работать со старым описанием или использовать новое.
В случае использования нового описания обязательно проверьте конфигурацию на
правильность. Рекомендуется использовать новое описание для старых конфигураций
только в том случае, если в нём появились необходимые вам функции.
Сохранение конфигурации
Для сохранения текущего проекта без создания конфигурации в главном меню
выберите «Файл» – «Сохранить» и введите нужное имя файла. При этом будет создан
файл проекта (с расширением scproj). Файл проекта не может быть загружен в СЧПУ.
Начало работы
В дереве проекта правой кнопкой щелкните на пункт «Программы», в контекстном
меню выберите "Добавить программу", в появившемся окне введите имя программы.
Программа появится в дереве проекта в разделе программ. Двойным щелчком откройте ее
для редактирования
Библиотека блоков
На панели библиотеки находятся доступные ресурсы ЧПУ, сгруппированные по
типу
I/O - ресурсы ввода/вывода
Motion - ресурсы контроллера движения
Functions - функциональные блоки
Kinematics - типы кинематики
Для получения более подробной справки о ресурсах СЧПУ обратитесь к документу
«СЧПУ СервоКон. Руководство интегратора»
Добавление блоков в программу
Перетащите элемент из библиотеки в окно редактирования. Любой фиксированный
ресурс может дублироваться в разных программах неограниченное число раз
Соединение блоков
Нажмите левую кнопку мыши на нужном входе/выходе. Удерживая кнопку,
подведите курсор ко второму входу/выходу. Если соединение невозможно, то соединение
окрасится в красный цвет. Отпустите кнопку - соединение будет создано.
Удаление блоков и соединений
Выберите соединение или блок и нажмите клавишу Delete или в контекстном меню
выберите "Удалить".
Перемещение блоков
Перетаскивайте блоки мышью. Для оптимизации расположения соединения два
раза щелкните на него мышью.
Добавление комментариев
На верхней панели инструментов выберите "Создать комментарий", обведите
рамкой необходимую область, и введите текст в появившееся окно.
Установка значений параметров
На панели инструментов выберите "Создать переменную", обведите рамкой
необходимую область и введите значение в поле «Значение» в появившемся окне.
Закройте окно и соедините получившийся блок с нужным параметром. Для изменения
значения дважды щелкните на блоке со значением и измените значение.
Редактирование таблиц инструментов
Для редактирования таблицы инструментов проекта выберите в главном меню
пункт «Правка» – «Таблица инструментов». Откроется окно редактирования таблицы
инструментов.
Для добавления таблицы инструментов или выбора новой таблицы нажмите кнопку
«Открыть» и выберите нужный файл таблицы или файл шаблона.
Для создания нового инструмента нажмите кнопку «Новый». Для удаления
инструмента выберите соответствующую строку и нажмите кнопку «Удалить». Для
редактирования параметров инструмента дважды щелкните на соответствующей ячейке,
введите нужное значение и нажмите «Enter».
Введите необходимые значения параметров инструментов и закройте окно. Для
сохранения таблицы для последующего использования в других конфигурациях нажмите
кнопку «Сохранить».
Создание конфигурации
В главном меню выберите «Файл» - «Создать конфигурацию». Отобразится окно с
сообщениями о прогрессе операции, в конце будет выведена информация об ошибках и
предупреждениях. Если конфигурация создана успешно (не было сообщений об ошибках),
программа предложит сохранить полученную конфигурацию.
Полученная конфигурация (с расширением scconfig) может быть загружена в
СЧПУ через USB-диск или сеть Ethernet.
Внимание! Для корректного отображения имени конфигурации на передней панели
СЧПУ имя файла не должно содержать русские буквы и спецсимволы.
Удаленная работа
Настройка подключения к СЧПУ
Для подключения к СЧПУ «СервоКон» по сети Ethernet необходимо задать в
программе ее адрес или доменное имя. Адрес СЧПУ предварительно должен быть задан с
передней панели (по умолчанию установлен адрес 192.168.2.26). Также возможно
обращение к СЧПУ по доменному имени: СЧПУ имеет доменное имя формата
servocon_<серийный номер>.local, (например servocon_12.local).
В главном меню выберите пункт СервоКон – Настройки, введите адрес СЧПУ и
нажмите кнопку OK.
Удаленная запись программ движения
В главном меню выберите пункт СервоКон – Записать программу и выберите
нужный файл программы движения. Файл должен иметь расширение nc, cnc или ngc.
Внимание! Для корректного отображения имени конфигурации на передней панели ЧПУ
имя файла не должно содержать русские буквы и спецсимволы.
Удаленная запись конфигурации.
В главном меню выберите пункт СервоКон – Записать конфигурацию и выберите
нужный файл конфигурации.
Режим отладки
Режим отладки позволяет анализировать работу СЧПУ и изменять параметры в
режиме он-лайн. Для перехода в режим отладки в главном меню выберите пункт
СервоКон – Начать отладку, при этом автоматически будет считана текущая
конфигурация СЧПУ.
Настройка значений параметров.
В режиме отладки изменения значений параметров в конфигурации автоматически
применяются и сохраняются в СЧПУ.
Внимание! Будьте внимательны при изменении параметров. Некорректные значения
параметров (например, неверные значения передаточных отношений приводов портала)
могут привести к физическому повреждению оборудования.
Осциллограф
Для просмотра текущих значений параметров на панели инструментов выберите
«Создать осциллограф», и обведите рамкой необходимую область. В программе появится
блок, к входам которого можно подключить любой параметр конфигурации.
Осциллограф имеет два режима работы:
Режим временной развертки: в данном режиме по оси X отображается время с
начала сбора данных в секундах, а по оси Y отображаются значения выбранных
параметров. Для использования данного режима подключите необходимые параметры ко
входам Y1 – Y4.
Режим плоттера: в данном режиме выбранне пары параметров отображаются в виде
кривой в плоскости XY. Этот режим полезен, например, при анализе максимального
отклонения траектории движения от заданной. Для использования данного режима
подключите необходимые пары параметров ко входам X1,Y1 и X2,Y2.
Для анализа изменений параметров дважды щелкните на блоке осциллографа.
Отобразится окно осциллографа.
Для начала сбора данных нажмите кнопку «Пуск». Для остановки сбора данных
нажмите кнопку «Стоп», при этом осциллограф буден автоматически отмасштабирован
под размер собранных данных.
В левом нижнем углу осциллографа отображаются минимальные значения
текущего окна по горизонтали и вертикали. В правом нижнем и левом верхнем углах
отображаются максимальные значения.
Для увеличения выбранной части графика, удерживая левую кнопку мыши,
обведите рамкой нужную область или подведите курсор к нужной точке и вращайте
колесико мыши. Для перемещения отображаемой области перемещайте мышь, удерживая
правую кнопку.
Для анализа разницы между показаниями используйте курсоры. При установке
флажков Cursor1 и Cursor2 курсоры отобразятся на экране. Для перемещения курсоров
перетасивайте их мышью за среднюю часть.
Под осциллографом отображается текущий шаг сетки, положение указателя мыши
и курсоров.
Скачать