Лайком Сафронов Лабораторная № 7 (2)

advertisement
Федеральное агентство по образованию
Государственное образовательное учреждение высшего
профессионального образования
«ТОМСКИЙ ПОЛИТЕХНИЧЕСКИЙ УНИВЕРСИТЕТ»
Институт – Институт Кибернетики.
Направление (специальность) – Информатики и Вычислительная техника
Кафедра - Оптимизации Систем Управления.
ЛАБОРАТОРНАЯ РАБОТА: Динамическая маршрутизация.
Отчет по лабораторной работе № 7.
По дисциплине Сети ЭВМ и ТК.
Выполнил
Студент группы 8В83
Студент группы 8В83
Руководитель
Старший преподаватель
________________
Подпись
________________
Дата
________________
Подпись
________________
дата
Д.Н. Лайком.
________________
Подпись
________________
дата
В.А. Дорофеев
Томск 2011.
Б.А. Сафронов.
Задание
Соединить и настроить маршрутизаторы для работы в сети со следующей топологией:
Рис 6. Сеть из четырёх маршрутизаторов.
После того, как сеть окажется в рабочем состоянии, отразите в отчёте все таблицы
маршрутизации и результаты трассировок путей. После этого включите режим
отладки протокола RIPv2, отключите один из кабелей, дождитесь перестройки
таблиц маршрутизации и отразите в отчете новые таблицы и результаты
трассировки.
Ход работы:
Лог файлы
Маршрутизатор 1:
router1#sh run
Building configuration...
Current configuration : 865 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$QcHb$PHe4ypihxrX63JcS7cRJm.
enable password 546833
!
no aaa new-model
ip cef
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
speed auto
half-duplex
no mop enabled
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
router rip
network 192.168.1.0
network 192.168.2.0!
ip http server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
end
Маршрутизатор 2:
router2#sh run
Building configuration...
Current configuration : 811 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$5cSP$RkDlSVbfHarvKqGXOet7P/
enable password cisco
!
no aaa new-model
ip cef
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.0
speed auto
half-duplex
no mop enabled
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
router rip
network 192.168.2.0
!
ip http server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
end
Маршрутизатор 3:
router3#sh run
Building configuration...
Current configuration : 812 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$X4oR$TMZiGcVlNBDZ4JXj7aq7r/
enable password 546833
!
no aaa new-model
ip cef
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
speed auto
half-duplex
no mop enabled
!
interface Serial0/2/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
router rip
network 192.168.0.0
!
ip http server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
end
Маршрутизатор 4:
router4#sh run
Building configuration...
Current configuration : 849 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router4
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$67o4$bvw4YA6RTfWR9oeF7OJIm1
enable password cisco
!
no aaa new-model
ip cef
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
speed auto
half-duplex
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
router rip
network 192.168.0.0
network 192.168.1.0
!
ip http server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
end
Результат работы программы:
router3#ping 192.168.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
router3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R
192.168.0.0/24 [120/1] via 192.168.1.1, 00:00:23, FastEthernet0/0
C
192.168.1.0/24 is directly connected, FastEthernet0/0
C
192.168.2.0/24 is directly connected, FastEthernet0/1
Вывод:
В результате лабораторной работы были освоены режимы, команды, конфигурация
интерфеса и команды мониторинга при динамической маршрутизации.
Приобретены навыки работы с протоколом RIP.
Download