Лабораторная работа №9 _ADO

Реклама
Отправка почтовых сообщений с помощью Outlook
Пример этого раздела иллюстрирует методы
программой Microsoft Outlook.
автоматизации
с
На рисунке показан рабочий лист, который содержит данные почтового
сообщения: имя, почтовый адрес и сумму предоставляемого пособия.
Процедура листинга просматривает строки (записи) этой рабочей книги и
создает на основе полученных данных отдельные сообщения (Сохраненные в
переменной Msg).
Листинг
Этот пример демонстрирует раннее связывание, поэтому в нем
применяются ссылки на библиотеку объектов Outlook. Обратите внимание,
что используется два объекта: Outlook и Mailltem. Первый был создан с
помощью следующего оператора.
Set OutlookApp = New Outlook.Application
Объект Mailltem создастся таким оператором.
Set Mitem = OutlookApp.CreateItem(olMailItem)
ADO
В вашей компании ведется учет товаров, которые имеются на складе,
при помощи таблицы Товары базы данных Борей, которая расположена в каталоге
C:\Program Files\Microsoft Office\OFFICE11\SAMPLES. В этой таблице
находятся следующие важные для вас столбцы:
�КодТовара —
�Марка —
�Цена —
идентификатор товара;
наименование продукта;
стоимость за единицу продукта;
�НаСкладе —
количество единиц этого товара на складе;
�МинимальныйЗапас —
минимально допустимое количество единиц данного
товара на складе. Если реальное количество единиц этого товара
меньше, чем это значение, то товар нужно срочно заказать;
�ПоставкиПрекращены —
флаг прекращения работы с товаром. Если в этом
столбце стоит единица, то это значит, что принято решение закупки
этого товара больше не производить.
Все остальные столбцы для целей этой работы можно игнорировать.
Заполнение
таблицы
Товары
производится
при
помощи
специализированного приложения, созданного достаточно давно и не
предусматривающего некоторых необходимых форм.
Вам поручено создать приложение на основе Excel, которое бы:
1. Производило вставку в лист Excel данных по всем строкам и всем
столбцам этой таблицы.
2. Генерировало бы в Excel дополнительные столбцы следующего
содержания:
• "Заказать товара, штук" — разница между столбцами МинимальныйЗапас и НаСкладе. В
этот столбец должна помещаться информация о количестве товара в штуках,
которое нужно срочно заказать. Эту информацию нужно генерировать только
для тех записей, для которых значение в столбце МинимальныйЗапас больше, чем в
столбце НаСкладе, и у которых значение столбца ПоставкиПрекращены установлено в
False;
• "Стоимость заказа" — определяло бы стоимость такого пополнения склада
для каждой строки в таблице. Стоимость заказа рассчитывается как
произведение предыдущего столбца и столбца Цена. Эту информацию также
нужно генерировать только для тех записей, для которых значение в столбце
МинимальныйЗапас больше, чем в столбце НаСкладе.
3. Вставляло бы в одной строке под полученными записями из базы
данных две итоговые строки:
• "Общая стоимость товаров на складе" — итоговая стоимость всех товаров, которые
находятся на складе (как сумма произведений столбцов НаСкладе и Цена для
каждой строки);
• "Общая стоимость товаров к заказу" — итог по столбцу СтоимостьЗаказа.
1. Создайте новый файл Excel, сделайте видимым панель управления
Элементы управления, щелкните в нем по элементу управления Кнопка и
поместите кнопку на лист Excel. Для наших целей мы будем считать, что
созданная кнопка занимает две верхние строки первого листа.
2. На панели инструментов Элементы управления щелкните по
кнопке Свойства (при этом созданная кнопка должна быть выделена) и
настройте для свойства Caption значение "Получить данные". Воспользуйтесь
свойством Font, чтобы настроить подходящий шрифт для вашей кнопки.
3. Щелкните правой кнопкой мыши по созданной вами кнопке и в
контекстном меню выберите Исходный текст. Откроется редактор Visual
Basic с курсором ввода на месте события Click для вашей кнопки.
4. В окне редактора кода в меню Tools выберите References и
установите флажок напротив строки Microsoft ActiveX Data Objects 2.1
Library.
5. Код для события Click вашей кнопки Получить данные может быть
таким, как показано далее.
Внимание! Для создания соединения с базой лучше сгенерировать
строки следующим образом:
Самый простой вариант — вообще ничего самому не писать. Значение
для этого свойства можно сгенерировать в автоматическом режиме.
Выглядит это очень просто:
1. Создаем любой пустой файл (например, текстовый). Для этого нужно
щелкнуть правой кнопкой мыши на пустом месте в окне проводника
Windows и в контекстном меню выбрать New | Text Document — рис. 9.2.
И затем задать создавшемуся файлу любое название.
Рис. 9.2. Создание пустого текстового файла в Windows Explorer
2. Переименовываем файл так, чтобы у него было расширение udl (от
User Data Link — пользовательское подключение к данным). После
переименования убедитесь, что иконка для него изменилась (рис. 9.3).
Рис. 9.3. Созданный файл 1.udl
Если она осталась такой же, как была для текстового документа, это
значит, что реальное расширение для этого файла — txt, а не udl.
В этом случае нужно в окне Windows Explorer в меню Tools выбрать
Folder Options, в окне Folder Options перейти на вкладку View и снять
флажок Hide file extensions for known file types (скрывать расширения для
известных типов файлов). После того, как вы выполните эту операцию,
измените расширение файла на udl.
3. После того, как UDL-файл будет создан, просто щелкните по нему
два раза левой кнопкой мыши. Откроется окно Data Link Properties с
четырьмя вкладками.
4. На первой вкладке Provider выберите нужный тип базы данных
(например, для базы данных SQL Server выберите Microsoft OLE DB
Provider for SQL Server, для подключения к базе Oracle — Microsoft OLE
DB Provider for Oracle, для подключения к базе Access — Microsoft JET 4.0
OLE DB Provider). Про подключение к листу Excel как к базе данных мы
поговорим отдельно в разд. 9.4.
5. Далее перейдите на вкладку Connection. Для каждого типа базы
данных эта вкладка выглядит по-своему. Например, для SQL Server она
выглядит так, как представлено на рис. 9.4, а для Access — на рис. 9.5.
Если вы не знаете, какие параметры вам нужно вводить в этом окне,
спросите у вашего администратора базы данных.
После того, как все параметры введены, рекомендуется нажать на
кнопку Проверить подключение (Test Connection), чтобы проверить
возможность подключения к базе данных. Если возникла ошибка, то нужно
исправить введенные вами параметры свойств соединения. После этого
нужно нажать кнопку OK, чтобы закрыть окно свойств соединения.
6. Последнее действие, которое нам потребуется сделать — щелкнуть
правой кнопкой мыши по созданному UDL-файлу, в контекстном меню
выбрать Open With | Choose Program и в появившемся списке выбрать
Notepad (Блокнот) и нажать кнопку OK.
Созданный вами файл откроется в блокноте. В меню Format в
блокноте снимите флажок Word wrap и скопируйте в буфер обмена
последнюю строку этого файла.
7. Осталось вставить скопированное значение в окно редактора кода
как значение свойства ConnectionString и взять его в кавычки.
Перед тем как ввести код подключите необходимые библиотеки
Скачать