(MS Word, 2.16Мб)

Реклама
1
Инструкция по основным задачам
администрирования MS SQL Server.
(для русской версии SQL Server).
Содержание:
1. Настройка служб SQL Server. ......................................................................... 2
2. Настройка сетевой конфигурации. ................................................................. 5
3. Присоединение/отсоединение баз данных. .................................................. 8
3.1. Отсоединение баз данных. .......................................................................... 8
3.2. Присоединение базы данных. ................................................................... 12
4. Мониторинг и управление процессами. ...................................................... 17
5. Настройка параметров подключения к серверу. ......................................... 23
5.1. Создание имени входа. .............................................................................. 23
5.2. Настройка параметров сервера ................................................................. 26
6. Работа с программой SQL Server Management Studio Express. ................. 31
6.1. Просмотр и редактирование содержания таблиц. .................................. 31
6.2. Запуск SQL-скриптов................................................................................. 35
2
1. Настройка служб SQL Server.
Для настройки конфигурации служб Microsoft SQL Server запустите
программу SQL Server Configuration Manager.
Пуск > Программы > Microsoft SQL Server 2005 >
Configuration Tools > SQL Server Configuration Manager.
В дереве объектов, расположенном в левой части окна программы
одинарным щелчком левой кнопки мыши выберите элемент «SQL Server
2005 Services» (службы SQL Server 2005). В отобразившемся в правой части
окна списке проверьте, запушены ли службы SQL Server и SQL Server
Browser (в колонке State должно стоять Running). Также проверьте,
установлен ли автоматический режим запуска службы (в колонке Start Mode
должно стоять Auto). См. рисунок 1. Помимо них в списке могут
присутствовать и другие службы, но их состояние в большинстве случаев
никак не отражается на работе программ.
Рисунок 1 - Окно SQL Server Configuration Manager. Службы.
Если у вас не запущена служба SQL Server, то вы не сможете работать
с программами, которые используют базы данных, расположенные на
сервере.
3
Чтобы запустить остановленную службу, а также изменить параметры
запуска службы, дважды щелкните левой кнопкой мыши по значку службы в
таблице. В открывшемся диалоге свойств службы на вкладке Log On
нажмите кнопку «Start» (рисунок 2).
Рисунок 2 - Диалог свойств службы. Вкладка Log On.
Чтобы изменить параметры запуска службы перейдите на вкладку
Service. В таблице свойств службы найдите пункт Start Mode и в поле со
списком выберите Automatic. См. рисунок 3.
4
Рисунок 3 - Диалог свойств службы. Вкладка Service.
Помимо встроенных инструментов, для настройки конфигурации
служб также можно использовать панель управления Windows.
5
2. Настройка сетевой конфигурации.
Для настройки сетевой конфигурации Microsoft SQL Server запустите
программу SQL Server Configuration Manager.
Пуск > Программы > Microsoft SQL Server 2005 >
Configuration Tools > SQL Server Configuration Manager.
В дереве объектов, расположенном в левой части окна программы
двойным щелчком левой кнопки мыши или однократным нажатием на значок
«+» раскройте элемент «SQL Server 2005 Network Configuration». Выберите
в подсписке элемент «Protocols for SQLEXPRESS». Если экземпляр вашего
сервера имеет имя, отличное от SQLEXPRESS, то этот пункт будет
называться иначе (например «Protocols for EP», если имя вашего экземпляра
сервера EP). В отобразившемся в правой части окна списке проверьте,
активны ли протоколы Shared Memory, Named Pipes и TCP/IP (в колонке
Status должно стоять Enabled). См. рисунок 4.
Рисунок 4 - Окно SQL Server Configuration Manager. Протоколы сервера.
Если указанные протоколы не активны (в колонке Status стоит
Disabled), их необходимо активировать. Выделите в списке соответствующий
6
элемент правой кнопкой мыши и в открывшемся контекстном меню
выберите пункт «Enabled».
Помимо
настроек
протоколов
сервера,
необходимо
настроить
клиентские протоколы. Для этого в дереве объектов, расположенном в левой
части окна программы двойным щелчком левой кнопки мыши или
однократным нажатием на значок «+» раскройте элемент «SQL Native Client
Configuration». Выберите в подсписке элемент «Client Protocols». В
отобразившемся в правой части окна списке проверьте, активны ли
протоколы Shared Memory, Named Pipes и TCP/IP (в колонке Status должно
стоять Enabled). См. рисунок 5.
Рисунок 5 - Окно SQL Server Configuration Manager. Клиентские протоколы.
При подключении к SQL-серверу сетевых компьютеров необходимо
отключить Брандмауэр Windows. Для этого войдите в Панель управления
Windows
Пуск > Настройка > Панель управления
Дважды щелкните по значку «Брандмауэр Windows» (см. рисунок 6).
7
Рисунок 6 - Панель управления Windows.
В открывшемся диалоге «Брандмауэр Windows» на вкладке «Общие»
выберите переключатель «Выключить» (см. рисунок 7).
Рисунок 7 - Диалог "Брандмауэр Windows".
Для сохранения настроек нажмите кнопку «ОК».
8
3. Присоединение/отсоединение баз данных.
Каждая база данных Microsoft SQL Server хранится на жестком диске
компьютера в виде двух файлов. Первый файл является файлом данных и
имеет расширение .mdf. Второй файл является логом транзакций и имеет
расширение .ldf. Имя файла обычно соответствует имени базы данных. Для
хранения файлов баз данных на компьютерах-серверах создана папка
MSSQLDB, которая расположена на диске C (см рисунок 8).
Рисунок 8 - Файлы баз данных.
В
некоторых
случаях
(например,
в
случае
копирования
или
перемещения файлов баз данных) требуется отсоединение баз данных от
SQL-сервера.
3.1. Отсоединение баз данных.
Чтобы отсоединить базу данных от сервера необходимо запустить
программу SQL Server Management Studio Express
Пуск > Программы > Microsoft SQL Server 2005 >
Среда SQL Server Management Studio Express
В диалоге «Соединение с сервером» укажите имя сервера и нажмите кнопку
«Соединить» (рисунок 9).
9
Рисунок 9 - Диалог "Соединение с сервером"
В главном окне программы найдите панель «Обозреватель объектов»
(рисунок 10). Если панель «Обозреватель объектов» не отображена, то в
главном меню программы нажмите Вид > Обозреватель объектов.
Рисунок 10 - Обозреватель объектов.
В дереве обозревателя объектов двойным щелчком мыши или
однократным нажатием на значок «+» раскройте элемент «Базы данных».
10
Выберите базу данных, которую необходимо отсоединить от сервера (в
данном случае Subs) См. рисунок 11.
Рисунок 11 - Выбранная база данных в обозревателе объектов.
Правой кнопкой мыши щелкните на выбранной базе данных, и в
открывшемся контекстном меню выберите:
Задачи > Отсоединить
В открывшемся окне «Отсоединение базы данных» нажмите кнопку
«ОК» (рисунок 12).
Рисунок 12 – Окно «Отсоединение базы данных».
11
Если же в процессе отсоединение базы данных будет выведено
сообщение об ошибке, тогда проверьте, не запушены ли программы,
использующие отсоединяемую базу данных. Если необходимо отсоединить
базу данных при наличии активных соединений, то в окне «Отсоединение
базы данных» в таблице «Базы данных для отсоединения» напротив
отсоединяемой базы данный необходимо установить флажок в колонке
«Удалить соединения» (см. рисунок 13). Нажмите кнопку «ОК».
Рисунок 13 - Отсоединение базы данных
при наличии активных соединений.
Если все программы, использующие восстанавливаемую базу данных
закрыты, и программа все равно выдает сообщение об ошибке, свяжитесь со
специалистами и сообщите код ошибки и текст сообщения об ошибке.
После отсоединения базы данных от сервера можно выполнять
различные действия с файлами базы данных (например, копирование
файлов).
12
3.2. Присоединение базы данных.
На компьютере, где установлен Microsoft SQL Server скопируйте
файлы базы данных, которые нужно присоединить, на жесткий диск.
Рекомендуется копировать файлы баз данных в папку MSSQLDB,
расположенную на диске C (см. рисунок 14).
Рисунок 14 - Скопированные файлы баз данных.
Чтобы присоединить базу данных к серверу необходимо запустить
программу SQL Server Management Studio Express
Пуск > Программы > Microsoft SQL Server 2005 >
Среда SQL Server Management Studio Express
В диалоге «Соединение с сервером» укажите имя сервера и нажмите кнопку
«Соединить» (рисунок 15).
13
Рисунок 15 - Диалог "Соединение с сервером"
В главном окне программы найдите панель «Обозреватель объектов»
(рисунок 16). Если панель «Обозреватель объектов» не отображена, то в
главном меню программы нажмите Вид > Обозреватель объектов.
Рисунок 16 - Обозреватель объектов.
В дереве обозревателя объектов двойным щелчком мыши или
однократным нажатием на значок «+» раскройте элемент «Базы данных».
Убедитесь, что база данных с таким же именем не подключена к
серверу (она должна отсутствовать в списке).
14
Правой кнопкой мыши щелкните по элементу «Базы данных» и в
раскрывшемся
контекстном
меню
выберите
пункт
«Присоединить»
(рисунок 17).
Рисунок 17 - Присоединение базы данных.
В открывшемся окне «Присоединение баз данных» нажмите кнопку
«Добавить» (см. рисунок 18).
Рисунок 18 – Окно «Присоединение баз данных».
15
В открывшемся диалоге выбора файлов выберите .mdf-файл
присоединяемой базы данных. Затем нажмите кнопку «ОК» (см. рисунок 19).
Рисунок 19 - Диалог выбора файла базы данных.
В диалоге «Присоединение базы данных» нажмите кнопку «ОК» (см.
рисунок 20).
16
Рисунок 20 – Окно «Присоединение баз данных».
Если выполнение всех действий прошло успешно, то в панели
«Обозреватель объектов» в списке «Базы данных» должна появиться
присоединенная база данных (см. рисунок 21).
Рисунок 21 - Присоединенная база данных.
Если при присоединении базы данных выдается сообщение об ошибке,
свяжитесь со специалистами для консультации и сообщите код ошибки и
текст сообщения об ошибке.
17
4. Мониторинг и управление процессами.
В
некоторых
случаях
(например,
перед
восстановлением
или
отсоединением базы данных) возникает необходимость определить, кто из
сетевых пользователей в настоящий момент подключен к SQL-серверу, а при
необходимости разорвать соединения. Для решения подобных задач можно
использовать инструмент «Монитор активности».
Чтобы
запустить
монитор
активности
необходимо
запустить
программу SQL Server Management Studio Express
Пуск > Программы > Microsoft SQL Server 2005 >
Среда SQL Server Management Studio Express
В диалоге «Соединение с сервером» укажите имя сервера и нажмите кнопку
«Соединить» (рисунок 22).
Рисунок 22 - Диалог "Соединение с сервером"
В главном окне программы найдите панель «Обозреватель объектов»
(рисунок 10). Если панель «Обозреватель объектов» не отображена, то в
главном меню программы нажмите Вид > Обозреватель объектов. В дереве
обозревателя объектов двойным щелчком мыши или однократным нажатием
на значок «+» раскройте элемент «Управление» и дважды щелкните по
элементу «Монитор активности» (см. рисунок 23).
18
Рисунок 23 - Запуск монитора активности.
На вкладке «Сведения о процессе» в таблице отображаются все
имеющиеся в данный момент подключения к серверу. Чтобы получить
актуальную информацию о запущенных в данный момент процессах
нажмите кнопку «Обновить» (см. рисунок 24).
Рисунок 24 - Окно монитора активности.
19
Обновление
информации
о
текущих
процессах
можно
автоматизировать. Для этого слева на панели «Состояние» нажмите кнопкугиперссылку «Просмотреть настройки обновления» (см. рисунок 25).
Рисунок 25 - Кнопка настроек обновления.
В открывшемся диалоге «Настройки обновления» установите флажок
«Автоматическое обновление каждые» и введите в поле периодичность
обновления списка процессов в секундах. Не рекомендуется устанавливать
значения периодичности обновления меньше 10 секунд. Нажмите кнопку
«ОК» (см. рисунок 26).
Рисунок 26 - Диалог "Настройки обновления".
Содержание некоторых колонок таблицы приведено в таблице 1.
20
Таблица 1 - Описание содержания таблицы процессов монитора активности.
Имя колонки
Пользователь
Описание
Имя
пользователя,
использующего
процесс.
Для
доменных сетей это имя доменного пользователя, для
одноранговых – локальный пользователь сервера
«Гость». Если вы используете авторизацию SQLсервера – имя пользователя SQL-сервера.
Базы данных
Имя базы данных, используемой процессом.
Команда
Текст команды на языке SQL, выполняемой в данном
процессе.
Приложение
Имя приложения (программы), использующей процесс.
Время входа
Время входа на сервер.
Последний пакет
Время приема/отправки последнего пакета клиенту.
Узел
Имя компьютера, использующего процесс.
Сетевой адрес
MAC-адрес сетевой карты компьютера, использующего
процесс.
Анализируя содержание данной таблицы можно выявить процессы,
мешающие выполнения некоторым операциям администрирования сервера
(например, восстановление базы данных из резервной копии). Например,
выделенная на рисунке 27 запись информирует нас о том, что на компьютере
с именем «SOROKIN_B» в 16:32:38 пользователем «Sorokin» (домен
MASTER)
открыта
программа
«LgReestr»
(Реестр
льготников),
использующая базу данных «Lgot».
Рисунок 27 – Процесс в списке.
Обратите внимание на процессы, которые используются самой
программой
администрирования.
Их
легко
выявить
по
колонке
21
«Приложение» и «Узел», значения которых будет «Microsoft SQL Server
Management Studio Express» и имя компьютера, где вами запушена программ
SQL Server Management Studio Express соответственно (обычно это
компьютер, где установлен SQL-сервер). Также эти процессы используют
системные базы данных (см. словарь терминов), такие как master, tempdb и
другие (см. рисунок 28).
Рисунок 28 - Процессы программы администрирования.
Чтобы закрыть процесс нужно одинарным щелчком правой кнопки
мыши выделить строку в списке процессов и в отрывшемся контекстном
меню выбрать «Завершить процесс» (см. рисунок 29).
Рисунок 29 - Завершение процесса.
В открывшемся диалоге «Завершить процесс» нажмите кнопку «Да»
(см. рисунок 30).
22
Рисунок 30 - Подтверждение завершения процесса.
Чтобы убедится, что закрытие процесса произошло успешно, нажмите
кнопку «Обновить». В случае успешного завершения процесса он должен
исчезнуть из списка.
Обратите внимание, что при завершении процесса на сервере
происходит только разрыв соединения с клиентской программой. Сама же
клиентская программа не закрывается и способна запускать другие процессы.
Поэтому все операции администрирования, которые требуют монопольного
доступа к базе данных (восстановление базы данных из резервной копии,
отключение базы данных и т. п.), рекомендуется выполнять сразу же после
закрытия процессов.
23
5. Настройка параметров подключения к серверу.
5.1. Создание имени входа.
Если вы используете одноранговую сеть (см. словарь терминов), то на
SQL-сервере нужно создать имя входа «Гость». Для этого запустите
программу SQL Server Management Studio Express
Пуск > Программы > Microsoft SQL Server 2005 >
Среда SQL Server Management Studio Express
В диалоге «Соединение с сервером» укажите имя сервера и нажмите
кнопку «Соединить» (рисунок 31).
Рисунок 31 - Диалог "Соединение с сервером"
В главном окне программы найдите панель «Обозреватель объектов».
Если панель «Обозреватель объектов» не отображена, то в главном меню
программы нажмите Вид > Обозреватель объектов.
В дереве обозревателя объектов двойным щелчком мыши или
однократным нажатием на значок «+» раскройте элемент «Безопасность», а
также подпункт «Имена входа». Если в списке отсутствует имя входа
«ИмяСервера\Гость», то его необходимо создать. Для этого правой кнопкой
мыши щелкните по элементу «Имена входа» и в открывшемся контекстном
меню выберите пункт «Создать имя входа» (см. рисунок 32).
24
Рисунок 32 - Создание нового имени входа.
В открывшемся окне «Создание имени входа» на вкладке «Общие»
выберите переключатель «Проверка подлинности Windows», и радом с
полем «Имя входа» нажмите кнопку «Найти» (см. рисунок 33).
Рисунок 33 - Окно "Создание имени входа".
В открывшемся диалоге «Выбор пользователя» в поле «Имена
выбираемых объектов» введите текст «Гость». Обратите внимание на место
25
поиска. Нужно искать пользователей на локальном компьютере. Нажмите
кнопку «Проверить». Если проверка прошла успешно, то в поле отобразится
текст «ИмяСервера\Гость». Нажмите кнопку «ОК» (см. рисунок 34).
Рисунок 34 - Диалог выбора пользователя.
Перейдите на вкладку «Серверные роли» и установите роль
«sysadmin». Нажмите кнопку «ОК» (см. рисунок 35).
Рисунок 35 - Назначение серверной роли.
Если все действия выполнены правильно, то в дереве обозревателя
объектов в списке «Имена входа» появится новый созданный элемент. Если
при создании имени входа произошла ошибка, повторите все действия заново
или обратитесь к специалистам для консультации.
26
5.2. Настройка параметров сервера
Для подключения к SQL-серверу сетевых компьютеров требуется
выполнить некоторые настройки. Для этого запустите программу SQL Server
Management Studio Express
Пуск > Программы > Microsoft SQL Server 2005 >
Среда SQL Server Management Studio Express
В диалоге «Соединение с сервером» укажите имя сервера и нажмите
кнопку «Соединить» (рисунок 36).
Рисунок 36 - Диалог "Соединение с сервером"
В главном окне программы найдите панель «Обозреватель объектов».
Если панель «Обозреватель объектов» не отображена, то в главном меню
программы нажмите Вид > Обозреватель объектов.
Правой кнопкой мыши щелкните по элементу экземпляра вашего
сервера (обычно это корневой элемент дерева) и в раскрывшемся
контекстном меню выберите пункт «Свойства» (см. рисунок 37).
27
Рисунок 37 - Контекстное меню экземпляра сервера.
В открывшемся окне «Свойства сервера» перейдите на страницу
«Соединения» и проверьте, установлен ли флажок «Разрешать удаленные
соединения с этим сервером». Если данный флажок не установлен –
установите его (см. рисунок 38).
Рисунок 38 - Свойства сервера, страница "Соединения".
28
Перейдите на страницу «Разрешения». Если ваша организация
использует доменную сеть (см. словарь терминов), то в таблице «Имена
входа и роли» выберите имя входа «BUILTIN\Пользователи» и проверьте,
установлены ли разрешения для «Connect SQL» и «Control Server». Если
данные разрешения не установлены или на них стоят запреты, установите
разрешения и снимите запреты (см. рисунок 39).
Рисунок 39 - Установка разрешений.
Если ваша организация использует одноранговую сеть (см. словарь
терминов), то в таблице «Имена входа и роли» выберите имя входа
«ИмяСервера\Гость» и проверьте, установлены ли разрешения для
«Connect SQL» и «Control Server». Если данные разрешения не
установлены или на них стоят запреты, установите разрешения и снимите
запреты (см. рисунок 40).
29
Рисунок 40 - Установка разрешений.
Для принятия изменений нажмите кнопку «ОК». Если при принятии
изменений программа выдает ошибку, повторите все действия заново или
обратитесь к специалистам для консультации. В некоторых случаях для
принятия изменений требуется перезапуск службы сервера. Для этого правой
кнопкой мыши щелкните по элементу экземпляра вашего сервера (обычно
это корневой элемент дерева), в раскрывшемся контекстном меню выберите
пункт «Перезапустить» (см. рисунок 41).
30
Рисунок 41 - Перезапуск службы сервера.
В диалоге подтверждения перезапуска нажмите кнопку «Да» (рисунок
42).
Рисунок 42 - Диалог подтверждения перезапуска службы.
Дождитесь окончания процесса выполнения перезапуска службы.
Показателем этого служит исчезновение с экрана диалога «Управление
службой» (см. рисунок 43).
Рисунок 43 - Диалог "Управление службой".
Если в процессе перезапуска произошла ошибка или система выдала
сообщение о невозможности остановки или запуска службы, обратитесь к
специалистам для консультации.
31
6. Работа с программой SQL Server Management Studio Express.
6.1. Просмотр и редактирование содержания таблиц.
В некоторых случаях в процессе администрирования базы данных
возникает необходимость непосредственного редактирования данных в
таблицах базы данных.
ВНИМАНИЕ!!! Неправильные действия при непосредственном
редактировании данных в таблицах базы данных могут привести к
нарушению работы программ, использующих эти базы данных.
Обязательно
консультируйтесь
со
специалистами
и
разработчиками, а также сохраняйте резервные копии баз данных
перед выполнением подобных действий.
Если же имеется необходимость редактирования данных прямо в
таблицах, обязательно свяжитесь со специалистами и уточните назначение
таблиц, полей и другие тонкости, которые необходимо знать для решения
вашей проблемы.
Запустите программу SQL Server Management Studio Express
Пуск > Программы > Microsoft SQL Server 2005 >
Среда SQL Server Management Studio Express
В диалоге «Соединение с сервером» укажите имя сервера и нажмите
кнопку «Соединить» (рисунок 44).
Рисунок 44 - Диалог "Соединение с сервером".
32
В
главном
окне
программы
найдите
панель
«Обозреватель
объектов». Если панель «Обозреватель объектов» не отображена, то в
главном меню программы нажмите Вид > Обозреватель объектов.
В дереве обозревателя объектов двойным щелчком мыши или
однократным нажатием на значок «+» раскройте элемент «Базы данных»,
выберите необходимую базу данных (например Lgot). Двойным щелчком
мыши или однократным нажатием на значок «+» раскройте элемент
выбранной базы данных, а в нем элемент «Таблицы» (см. рисунок 45).
Рисунок 45 - Раскрытие списка таблиц базы данных.
В списке таблиц выберите таблицу, содержание которой нужно
отредактировать. Рассмотрим редактирование на примере таблицы Config.
Правой кнопкой мыши щелкните по элементу нужной таблицы и в
открывшемся контекстном меню выберите пункт «Открыть таблицу» (см.
рисунок 46).
33
Рисунок 46 - Открытие таблицы “Config”.
В правой части главного рабочего окна программы на новой вкладке
должна открыться сетка таблицы (см. рисунок 47).
Рисунок 47 - Открытое содержание таблицы "Config".
Обратите внимание, что столбцы, содержание которых выделено серым
цветом являются столбцами только для чтения и редактирование данных в
них невозможно (см. рисунок 48).
34
Рисунок 48 - Столбец только для редактирования.
Чтобы отредактировать значение той или иной записи необходимо при
помощи левой кнопки мыши выделить ячейку, затем клавишами Delete или
Backspace удалить старое значение и ввести с клавиатуры компьютера новое
(см. рисунок 49).
Рисунок 49 - Отредактированное значение ячейки.
Обратите внимание, что все поля (столбцы) имеют разные типы данных
(символьный, числовой целый, числовой с плавающей точкой, логический и
т. п.), а также различные ограничения, которые нужно учитывать при
редактировании данных. Подобные вопросы необходимо уточнять у
специалистов.
Чтобы закончить редактирование данных нажмите клавишу Enter. Если
при
редактировании
программа
выдает
сообщение
об
ошибке,
проконсультируйтесь со специалистами.
Чтобы удалить запись в таблице выделите запись полностью путем
щелчка левой кнопкой мыши по боковой панели сетки (см. рисунок 50).
Рисунок 50 - Выделение записи.
35
Затем нажмите на клавиатуре компьютера клавишу Delete. В
открывшемся диалоге подтверждения удаления записи нажмите кнопку «Да»
(рисунок 51).
Рисунок 51 - Диалог подтверждения удаления записи.
В случае успешного удаления запись (строка) должна исчезнуть из
отображаемой таблицы. Если при удалении записи программа выдает
сообщение об ошибке, проконсультируйтесь со специалистами.
6.2. Запуск SQL-скриптов.
В
процессе
администрирования
баз
данных
иногда возникает
необходимость выполнения на сервере так называемых SQL-скриптов. SQLскрипт – это текстовый файл с расширением *.sql, в тексте которого
содержится набор команд на языке SQL. Данные файлы пишутся
специалистами для таких задач, как исправление ошибок в базе данных,
изменение настроек и конфигурации сервера, проверка и правка данных и т.
п.
ВНИМАНИЕ!!!
Неправильные
действия
при
запуске
SQL-
скриптов могут привести к нарушению работы программ и
необратимой
потере
Обязательно
данных,
изменению
консультируйтесь
со
настроек
сервера.
специалистами
и
разработчиками, а также сохраняйте резервные копии баз данных
перед выполнением подобных действий. Не запускайте SQLскрипты, происхождение и назначение которых вам неизвестно. Не
вносите
самостоятельно
изменения
в
текст
скриптов.
Не
запускайте дважды один и тот же скрипт, если это не оговорено
специалистами.
36
SQL-скрипты обычно передаются разработчиками программы или
специалистами по сопровождению по электронной почте в виде вложенных
файлов или на электронных носителях информации.
В сопроводительном письме обычно оговаривается назначение и
особенности запуска скрипта, а также краткая инструкция по контролю над
правильностью его исполнения. Тем не менее, перед выполнением данных
файлов обязательно связывайтесь со специалистами для исключения
непредвиденных ситуаций.
Чтобы выполнить SQL-скрипт запустите программу SQL Server
Management Studio Express
Пуск > Программы > Microsoft SQL Server 2005 >
Среда SQL Server Management Studio Express
В диалоге «Соединение с сервером» укажите имя сервера и нажмите
кнопку «Соединить» (рисунок 52).
Рисунок 52 - Диалог "Соединение с сервером".
В главном меню программы нажмите
Файл > Открыть > Файл
см. рисунок 53.
37
Рисунок 53 - Открытие файла.
В диалоге открытия файла выберите нужный файл с расширением *.sql.
и нажмите кнопку «Открыть» (см. рисунок 54).
Рисунок 54 - Диалог открытия файла.
Часто после открытия на экране появляется диалог подключения к
серверу, аналогичный тому, что изображен на рисунке 52. Если такой диалог
появился – введите имя сервера в поле «Имя сервера» и нажмите кнопку
«Соединить».
После открытия файла в рабочей области программы отобразится текст
скрипта. В верхней части обычно пишутся комментарии, в которых
38
содержится
информация
об
авторах,
дате
создания,
особенности
выполнения и т. п. В редакторе запросов программы SQL Server Managment
Studio Express они выделены зеленым цветом (см. рисунок 55).
Рисунок 55 - Комментарий к SQL-скрипту.
Несмотря
на
то,
что
выбор
целевой
базы
данных
обычно
прописывается в сценарии, рекомендуем вам вручную выбрать целевую базу
данных на панели инструментов программы. Для запуска нажмите кнопку
панели инструментов «Выполнить» (см. рисунок 56).
Рисунок 56 - Панель инструментов.
39
В зависимости от содержания скрипта, его выполнение занимает
различное время, от мгновенного до нескольких минут. Приблизительное
время выполнения тех или иных сценариев можно уточнить у специалистов.
После выполнения скрипта в нижней части панели редактора появится
информационная панель с вкладками. Перейдите на вкладку «Сообщения»,
где расположено поле вывода сообщений. При успешном выполнении в поле
вывода сообщений будет отображено сообщение об успешном выполнении.
Помимо
этого
некоторые
скрипты
в
данном
поле
отображают
промежуточные результаты и служебные сообщения, о которых можно
узнать у специалистов. Также об успешном выполнении сценария
свидетельствует зеленый значок, расположенный слева под полем вывода
сообщений (см. рисунок 57).
Рисунок 57 - Поле вывода сообщений при успешном выполнении скрипта.
Если же в процессе выполнения скрипта произошла ошибка, то в поле
вывода сообщений будет выведено соответствующее сообщение. Также об
ошибке
при
выполнении
сценария
свидетельствует
желтый
расположенный слева под полем вывода сообщений (см. рисунок 58).
значок,
40
Рисунок 58 - Поле вывода сообщений при ошибке.
В
случае
возникновения
подобной
ошибки
свяжитесь
со
специалистами для консультации и сообщите им текст, отображенный в поле
вывода сообщений.
Скачать