Лабораторная работа № 1 - Институт цветных металлов и

Реклама
Институт цветных металлов и материаловедения СФУ
Кафедра автоматизации производственных процессов
ЦМ
Дисциплина “Интегрированные
системы
проектирования и управления ”
Красноярск 2009 г.
Лабораторная работа № 1
“Изучение пакета Control System Toolbox системы MATLAB 7
и его применения для расчета систем управления”
ЦЕЛЬ РАБОТЫ
1. Ознакомиться с составом и назначением программного пакета Control System.
2. Ознакомиться с основными командами и примерами использования
программного пакета Control System в расчетах систем управления.
3. Освоить расчет, настройку и анализ одноконтурных САР в среде Control System
Toolbox системы MATLAB 6.
4. Освоить использование графического интерфейса пользователя LTI-viewer в
пакете Control System.
МЕТОДИКА ВЫПОЛНЕНИЯ РАБОТЫ
1. Открыть рабочее окно программы MATLAB 6.
2. Изучая теоретические сведения о пакете Control System, вводить в рабочем окне
команды, приводимые в описании пакета и выделенные желтым цветом.
3. Закончив изучение теоретических сведений о пакете Control System, выполнить
задание по моделированию СУ.
НЕКОТОРЫЕ ПОЛЕЗНЫЕ СВЕДЕНИЯ ДЛЯ РАБОТЫ В MATLAB
Переменные
В MATLAB нет необходимости в определении типа переменных или размерности.
Когда MATLAB встречает новое имя переменной, он автоматически создает
переменную и выделяет соответствующий объем памяти. Если переменная уже
существует, MATLAB изменяет ее состав и если это необходимо выделяет
дополнительную память. Например,
num_students = 25
создает матрицу 1x1 с именем num_students и сохраняет значение 25 в ее единственном элементе.
Имена переменных состоят из букв, цифр или символов подчеркивания. MATLAB
использует только первые 31 символ имени переменной. MATLAB чувствителен к
регистрам, он различает заглавные и строчные буквы. Поэтому А и а - не одна и та
же переменная. Чтобы увидеть матрицу связанную с переменной, просто введите
название переменной.
Числа
MATLAB использует принятую десятичную систему счисления, с необязательной
десятичной точкой и знаками плюс-минус для чисел. Научная система счисления
использует букву е для определения множителя степени десяти. Мнимые числа
используют i или j как суффикс. Некоторые примеры правильных чисел приведены
ниже
3
9.6397238
И
-99
1.60210е-20
-3.14159J
0.0001
6.02252е23
3e5i
Все числа для хранения используют формат long, определенный стандартом
плавающей точки ШЕЕ. Числа с плавающей точкой обладают ограниченной
точностью - приблизительно 16 значащих цифр и ограниченным диапазоном приблизительно от 10~308 до 10308 (Компьютер VAX использует другой формат чисел с
плавающей точкой, но их точность и диапазон приблизительно те же).
Операторы
Выражения используют обычные арифметические операции и правила старшинства.
+
*
/
\
л
'
()
сложение
вычитание
умножение
деление
левое деление
степень
комплексно сопряженное транспонирование
определение порядка вычисления
Функции
MATLAB предоставляет большое количество элементарных математических
функций, таких как abs, sqrt, exp, sin. Вычисление квадратного корня или логарифма
отрицательного числа не является ошибкой: в этом случае результатом является
соответствующее комплексное число. MATLAB также предоставляет и более
сложные функции, включая Гамма функцию и функции Бесселя. Большинство из
этих функций имеют комплексные аргументы. Чтобы вывести список всех
элементарных математических функций, наберите
help elfun
Для вывода более сложных математических и матричных функций, наберите
help specfun
help elmat
соответственно.
Некоторые функции, такие как sqrt и sin, - встроенные. Они являются частью
MATLAB, поэтому они очень эффективны, но их вычислительные детали трудно
доступны. В то время как другие функции, такие как gamma и sink, реализованы в
М-файлах. Поэтому вы можете легко увидеть их код и, в случае необходимости, даже
модифицировать его.
Несколько специальных функций предоставляют значения часто используемых
констант.
pi
3.14159265...
i
мнимая единица,  1
j
то же самое, что и i
eps
относительная точность числа с плавающей точкой, 2~52
realmin
наименьшее число с плавающей точкой, 2"1022
realmax
наибольшее число с плавающей точкой, (2-е)21023
Inf
бесконечность
NaN
не число
Бесконечность появляется при делении на нуль или при выполнении математического выражения, приводящего к переполнению, т.е. к превышению realmax. Не
число (NaN) генерируется при вычислении выражений типа 0/0 или Inf- Inf, которые
не имеют определенного математического значения.
Имена функций не являются зарезервированными, поэтому возможно изменять их
значения на новые, например
eps = 1.e-6
и далее использовать это значение в последующих вычислениях. Начальное значение
может быть восстановлено следующим образом
clear eps
Вы можете вводить матрицы в MATLAB несколькими способами:
• вводить полный список элементов
• загружать матрицы из внешних файлов
• генерировать матрицы, используя встроенные функции
• создавать матрицы с помощью ваших собственных функций в М-файлах
Начнем с введения матрицы Дюрера как списка элементов. Вы должны следовать
нескольким основным условиям:
• отделять элементы строки пробелами или запятыми
• использовать точку с запятой,;, для обозначения окончания каждой строки
• окружать весь список элементов квадратными скобками, [ ].
Чтобы ввести матрицу Дюрера просто напишите:
MATLAB отобразит матрицу, которую мы ввели,
Более подробную информацию можно найти в лабораторной работе 0, в
документах: MATLAB и MATLAB Simulink & Toolboxes
ТЕОРЕТИЧЕСКИЕ СВЕДЕНИЯ
Одним из основных инструментариев разработчика систем управления (СУ) в
среде MATLAB 6 является пакет Control System Toolbox. Это сборник алгоритмов
MATLAB для моделирования, анализа и проектирования СУ. В пакете используются
как традиционные методы ТАУ с использование передаточных функций, так и
современные методы с использованием пространства состояния. В среде Control
System Toolbox можно моделировать и анализировать как непрерывные, так и
дискретные СУ. Легко могут быть вычислены и отображены на экране отклики
системы в частотной и временной областях, диаграммы расположения
нулей/полюсов.
ОСНОВНЫЕ СВОЙСТВА ПАКЕТА Control System
Формы представления
 Непрерывные и дискретные СУ.
 Форматы моделей: передаточные функции (ПФ), пространство состояний (ПС),
нули-полюса (НП).
 Построение линейных моделей СУ.
 Преобразование моделей в различные форматы: ПФ, НП, ПС.
Анализ
 Полный набор средств для анализа одно- (SISO) и многомерных (MIMO) систем.
 Временные характеристики: переходная и импульсная переходная
характеристики, реакция системы на произвольное воздействие.




 Частотные характеристики: диаграммы Боде (АЧХ, ФЧХ), Найквиста и
Никольса (АФХ) и др.
Проектирование
Расчет параметров обратной связи.
Проектирование линейно-квадратичных регуляторов (LQR).
Характеристики моделей: управляемость, наблюдаемость, понижение порядка
модели.
Поддержка систем с запаздыванием.
Пакет часто используется совместно с другими пакетами MATLAB для
проектирования более сложных СУ.
LTI Модели
Пакет Control System Toolbox предназначен для работы с линейными
независимыми (инвариантными) от времени (англ. - Linear Time-Invariant или LTI)
системами. Эти системы могут быть как одномерными (SISO - single-input/singleoutput), так и многомерными (MIMO - multiple-input/ multiple-output). LTI системы
задаются в виде:
 передаточной функции ПФ (англ. Trasfer Function , TF)
P ( s) 
N ( s)
s 2  3s  2
P
(
s
)

, например,
;
D( s )
s 3  4 s 2  12 s  4
 нулей-полюсов-коэффициента усиления НПК (англ. Zero-Pole-Gain, ZPK)
H ( s)  k
( s  3)( s  10)
( s  z 1 )...( s  z m )
, например, H ( s )  2
;
( s  5)( s  3)( s  6)
( s  p1 )...( s  p n )
 пространства состояний ПС (англ. State Space, SS)
dx
 Ax  Bu;
dt
y  Cx  Du,
где х -вектор переменных состояния; u и y - вектора входа и выхода;
 данных частотного отклика (англ. Frequency Response Data, FRD), где каждой
частоте ωi входного синусоидального воздействия u = sin ωi t соответствует отклик
системы y = G(ωi) sin (ωi t + φi ) на это воздействие.
Команды создания LTI моделей
 Передаточная функция - ПФ (TF)
TF SISO модель h( s ) 
n( s )
характеризуется числителем (numerator) n(s) и
d ( s)
знаменателем (denominator) d(s), заданных в виде полиномов переменной s. MATLAB
оперирует с полиномами в виде векторов-строк коэффициентов полинома,
упорядоченных в порядке убывания степеней s. Так, например, [1 3 5] представляет
полином s2 +3 s + 5. Если num и den представляют n(s) и d(s), то команда
h = tf(num, den)
создает TF SISO модели h(s) = n(s)/ d(s). Переменная h это TF, содержащая данные
числителя и знаменателя. Например, строка
h = tf([1 0], [1 2 10])
создает TF h(s) = s /( s2 + 2 s + 10). При этом MATLAB выводит в командное окно
сообщение
Trasfer function:
s
--------------------s^2 + 2 s + 10
TF MIMO модели - это массив элементарных TF SISO моделей, задаваемых
своими числителями и знаменателями, или, что эквивалентно, массивом ячеек
числителей и массивом ячеек знаменателей. Например, массивы
 s1 
s  1 
N ( s)  
D( s )   2


 s  2
 s  4 s  5
задают ПФ


H ( s)  
 2
s
s 1 
s1 
s2 .

 4s  5 
Используя массивы данных векторов-строк для представления массивов
полиномов N(s) и D(s), TF MIMO модели можно задать, напечатав
N = {[1 -1];[1 1]}
% массив ячеек полиномов N(s)
D = {[1 1]; [1 4 5]}
% массив ячеек полиномов D(s)
H = tf (N, D)
.
MATLAB отвечает сообщением
Transfer function from input to output...
s–1
#1:
----s+1
s+2
#2:
----------------s^2 + 4 s + 5
Для обычной TF MIMO модели элементы N[i, j] и D[i, j] должны быть векторстроками числителя и знаменателя Hij(s).
По другому TF N(s) можно задать, используя операцию конкатенации
(связывания - concatention) TF SISO моделей
h11 = tf([1 –1],[1 1])
% (s–1)/(s+1)
h21 = tf([1 2],[1 4 5])
% (s+2)/(s^2+4s+5)
H = [h11;h21]
.
Такой синтаксис отражает стандартную конкатенацию матриц, он более прост и
более надежен для задания TF MIMO систем со многими входами и (или) выходами.
В MATLAB версии 6.0 предусмотрен и более простой способ задания ПФ системы
с использованием символического определения оператора Лапласа s. Ввод команды s
= tf('s') позволяет затем определять ПФ H(s) в виде рациональной дроби –
отношения полиномов числителя и знаменателя.
Так, при вводе команды
s = tf('s'); H = (s+1)/(s^2+3*s+1)
MATLAB выдает сообщение
Transfer function:
s+1
------------s^2 + 3 s + 1
.
 Нули-Полюса-Коэффициенты усиления - НПК (ZPK)
Для создания SISO моделей в виде ZPK, где нули и полюса - соответственно,
корни полиномов числителя и знаменателя
H ( s)  k
( s  z1 )...( s  z m )
,
( s  p1 )...( s  pn )
используют команду с синтаксисом
h = zpk(z, p, k)
,
где z и p -вектора-строки нулей и полюсов, k - усиление (скалярная величина). Эта
команда создает ZPK объект h, который включает в себя данные z, p и k. Так,
напечатав
h = zpk(0, [1 2], -2)
,
получим сообщение
Zero/pole/gain:
-2 s
----------(s-1) (s-2)
.
В MATLAB 6.0 предусмотрено задание ПФ системы в формате ZPK также и с
использованием символического определения оператора Лапласа s.
Ввод команды s = zpk('s') позволяет определять ПФ H(s) в виде рациональной
дроби – отношения нулей и полюсов в числителе и знаменателе, соответственно.
Введя команду
s = zpk('s'); H = -2*s/((s-1)*(s-2))
,
получим сообщение
Zero/pole/gain:
-2 s
----------(s-1) (s-2) .
Как видно, символический способ задания ПФ в формате ZPK менее
компактный, хотя и более наглядный.
Для создания MIMO ZPK моделей с p выходами и m входами используют
команду
H = zpk(Z,P,K)
,
где Z - p х m массивы ячеек нулей (Z{i,j} = нули Hij),
P - p х m массивы ячеек полюсов (P{i,j} = полюса Hij),
K - p х m матрица коэффициентов усиления (K(i,j) = коэффициенты усиления
Hij), p - число строк, m - число столбцов матриц и массивов.
Например, напечатав
Z = {[ ], -5;[1-i 1+i] [ ]}
% используйте [ ] , если нет нулей
P = {0,[-1 -1];[1 2 3],[ ]}
K = [-1 3; 2 0]
H = zpk(Z,P,K)
получим ZPK модель с двумя входами/двумя выходами
1
3( s  5) 


s
( s  1) 2 

.
H ( s) 
2
2
(
s

2
s

2
)

0 
 ( s  1)( s  2)( s  3)

 Пространство состояния - ПС (SS)
Модели в пространстве состояний используют для описания динамики системы
линейные дифференциальные или разностные уравнения. Для непрерывных систем
уравнения входа и выхода имеют вид
dx
 Ax  Bu;
dt
y  Cx  Du,
где x - вектор переменных состояния; u и y -вектора входа (управления) и выхода.
Для создания SS моделей используют команду
sys = ss(A,B,C,D)
,
что создает модель с именем sys, содержащую матрицы ПС - A, B, C, D, которые
должны иметь совместимые размерности строк и столбцов, как показано ниже.
Nx { A
B
Ny { C

D

N x Nu
 N x  число переменных состояния;

 N u  число входов;
 N  число выходов.
 y
Для моделей с нулевой матрицей D используют выражение D = 0.
Для иллюстрации метода SS рассмотрим простую модель электродвигателя
d 2θ
dθ
 2  5θ  3 I ,
2
dt
dt
где  - угловое перемещение ротора, а I - ток двигателя. Связь между входным током
u = I и угловой скоростью y = d/dt описывается уравнениями состояния
dx
 Ax  Bu;
dt
y  Cx.
где
 
0 
0 1
x   dθ  , A  
,
B

 3 , C  0 1.
 
  5  2
 
 dt 
Для создания такой SS модели необходимо набрать
sys = ss([0 1;-5 -2],[0; 3],[0 1], 0)
.
Обобщением стандартных SS моделей является дескрипторная SS модель, которая
описывается выражением
dx
 Ax  Bu;
dt
y  Cx  Du,
E
где E - дескрипторная часть в виде матрицы.
Такая модель удобна в случае, если матрица E плохо обусловлена для
инвертирования. Дескрипторная SS модель создается командой
sys = dss(A,B,C,D,E).
 Модели данных частотного отклика - (FRD)
Для создания моделей FRD используется команда
SYS = frd(RESPONSE,FREQS)
,
в которой RESPONSE – данные отклика системы SYS; FREQS – частоты
синусоидальных воздействий в рад/с. В дальнейшем эти модели легко преобразуются
в модели TF, ZPK, SS для последующего анализа, синтеза систем регулирования.
 Дискретные модели
Для создания дискретных моделей используются те же команды tf, zpk, ss, frd с
добавлением в их синтаксис времени выборки (периода квантования) Ts (в секундах)
sys = tf(num,den,Ts)
sys = zpk(z,p,k,Ts)
sys = ss(a,b,c,d,Ts)
sys = frd(response,freqs,Ts)
Например, строка команды
h = tf([1 1],[1 -0.5],0.1)
задает дискретную TF модель h(z) = (z - 1)/(z - 0.5) со временем выборки 0.1 секунд
Transfer function:
z+1
------z - 0.5
Sampling time: 0.1
Команда
sys = ss(A,B,C,D,0.5)
задает дискретную SS модель
x [n  1]  A x[n]  B u[n];
y [n]  C x [n]  D u [n],
со временем выборки 0.5 секунд. Вектора x[n], u[n], y[n] - значения вектора
переменных состояния, входа и выхода в n-й момент выборки.
По умолчанию для непрерывных систем время выборки Ts = 0. Используйте
значение Ts = –1, чтобы оставить время выборки дискретных систем не указанным.
Так, команда
h = tf([1 -0.2],[1 0.3],-1)
приводит к ответу MATLAB
Transfer function:
z – 0.2
------z + 0.3
Sampling time: unspecified
 Дискретная TF функция в DSP формате
При цифровой обработке сигналов (DSP - Digital Signal Processing) передаточную
функцию обычно записывают в виде рационального выражения с использованием z
–1
, а числитель и знаменатель содержат коэффициенты полиномов в порядке
возрастания степеней z –1 . Например, числитель и знаменатель выражения
1  0. 5 z  1
H (z ) 
1  2 z 1  3 z  2
1
нужно указать как вектора-строки [1 0.5] и [1 2 3], а это противоречит обычному
правилу уменьшения степеней z. Чтобы избежать этого, Control System Toolbox имеет
специальную функцию filt для задания DSP формата. Ее синтаксис
h = filt(num,den)
для дискретных TF моделей без указания времени выборки и
h = filt(num,den,Ts)
для дискретных TF моделей с указанием времени выборки. Эта функция создает TF
модели как и команда tf, но требует перечисления коэффициентов num и den в
порядке возрастания степеней z –1. Так, строка h = filt([1 0.5],[1 2 3])
дает ответ
Transfer function:
1 + 0.5 z^–1
------------------1 + 2 z^–1 + 3 z^–2 .
 Извлечение данных из моделей
Функции tf, zpk, ss сохраняют данные модели в едином LTI объекте. Для
извлечения в случае необходимости этих данных из существующего LTI объекта
используют команды:
[num,den,Ts] = tfdata(sys)
% Ts = период выборки (sample time)
[z,p,k,Ts] = zpkdata(sys)
% у непрерывных систем Ts нет (= 0)
[a,b,c,d,Ts] = ssdata(sys)
[a,b,c,d,e,Ts] = dssdata(sys)
Выходные аргументы num, den команды tfdata и z, p, k команды zpkdata всегда
являются массивами ячеек, даже в случае SISO модели.
Так, строка
H = [tf([1 -1],[1 2 10]) , tf(1,[1 0])]
создает ПФ с одним выходом/двумя входами
s 1

H ( s)   2
 s  2 s  10
1
s 
Набрав строку для извлечения числителей первого канала входа
[num,den] = tfdata(H)
num{1,1}
,
получим ответ MATLAB
ans =
0
1
-1
.
Набрав строку
den{1,1}
,
получим ответ MATLAB
ans =
1
2
10
.
Для получения числителя и знаменателя SISO модели непосредственно в виде
вектор-строки используют такой синтаксис команды
[num,den,Ts] = tfdata(sys,'v')
Так, набрав
sys = tf([1 3],[1 2 5])
[num,den] = tfdata(sys,'v’)
,
получим ответ
num =
0
1
3
den =
1
2
5
.
Аналогично команда
[z,p,k,Ts] = zpkdata(sys,'v')
возвращает значения нулей z и полюсов p модели в виде векторов-строк.
 Преобразование моделей
Преобразование моделей осуществляется теми же командами - tf, zpk и ss. Если
LTI модель обозначена как sys, то синтаксис команд таков:
sys = tf(sys)
% Преобразование в TF модель;
sys = zpk(sys)
% Преобразование в ZPK модель;
sys = ss(sys)
% Преобразование в SS модель.
sys = акв(sys)
% Преобразование в АКВ модель.
Например, для преобразования SS модели
sys = ss(-2,1,1,3)
в ZPK модель наберите команду
zpk(sys)
.
MATLAB ответит
Zero/pole/gain:
3 (s+2.333)
-------------(s+2)
Многие функции и операции MATLAB осуществляют автоматическое
преобразование в необходимый тип модели.
Осторожно! При манипуляциях и преобразовании LTI моделей имейте в виду,
что три вида моделей не одинаковы по точности вычислений. Самые точные
вычисления у SS моделей, затем у ZPK и наконец, TF моделей.
Поэтому, по возможности, работайте с SS моделями. Избегайте без крайней
необходимости преобразований моделей из одного формата в другой и обратно.
При операциях с моделями различного типа MATLAB использует следующую
иерархию результатов вычислений: SS > ZPK > TF. То есть,
 если хоть одна модель имеет SS формат, то результат всегда будет в SS форме;
 если одна модель имеет ZPK формат и нет SS моделей, то результат будет в
ZPK формате;
 если все модели имеют TF формат, то и окончательный результат тоже буде в
TF формате.
 Операции над моделями

 Сложение и вычитание
Операция сложения соединяет системы параллельно. Так, строка
sys = sys1 + sys2
возвращает LTI модель sys с параллельным соединением sys1 и sys2
Если H1 и H2 - это TF матрицы sys1 и sys2, то u и y связаны выражением
y =( H1 + H2) u .
При вычитании строка
sys = sys1 – sys2
создает систему sys, для которой
y =( H1 – H2) u .
 Умножение
Операция умножения соединяет системы последовательно. Так,
sys = sys1 * sys2
возвращает LTI модель sys с последовательным соединением sys1 и sys2
Обратите внимание на обратный порядок sys1 и sys2 на блочной схеме. Это
обусловлено порядком вычислений. Если H1 и H2 - это TF матрицы sys1 и sys2, то
порядок таков:
y = H1 v = H1(H2 u) = (H1 x H2) u.
 Конкатенация
Конкатенация моделей осуществляется матрично подобном видом:
sys = [sys1 , sys2] % горизонтальная конкатенация;
sys = [sys1 ; sys2] % вертикальная конкатенация.
В терминах ввода/вывода эти две операции имеют следующие блочные
интерпретации
u 
y  H 1 , H 2   1 
u2 
 y1 
   H 1 , H 2  u
 y2 
Горизонтальная конкатенация
Вертикальная конкатенация
С помощью операции конкатенции легко создавать MIMO TF и ZPK модели.
Так, строка
H = [ tf(1,[1 0]) 1 ; 0 tf([1 –1],[1 1]) ]
создается TF MIMO модель
1

H ( s)   s
0


1 
s  1

s  1
.
 Учет запаздывания
Запаздывание в непрерывных системах поддерживается MATLAB в пределах
совместимости отдельных моделей. Так, для TF моделей запаздывание (time delay)
задается введением в команду строки 'inputdelay', его значение. Например, строка
sys_tfdelay = tf(1.5, [1 14 40.02],'inputdelay',0.05)
приводит к ответу MATLAB
Transfer function:
1.5
exp(-0.05*s) * --------------------------s^2 + 14 s + 40.02
Срока
H = tf({1 , [1 2]},{[1 0] [1 2 5]},'inputdelay',[0 0.2])
приводит к ответу MATLAB
Transfer function from input 1 to output:
1
s
Transfer function from input 2 to output:
s+2
exp(-0.2*s) * ---------------------s^2 + 2 s + 5.
Для SS моделей запаздывание задается аналогично:
sys = ss(-1,[1 2],[2;1],0,'inputdelay',[0.1 0.05]) % SS модель, два входа, два выхода и
два значения Ts системы.
Так как многие команды для LTI объектов не поддерживают такое задание
запаздывания, приводящее к иррациональным функциям, то для рациональной
аппроксимации запаздывания используют функцию Паде n-го порядка, которая
заменяет трансцендентную ПФ звена запаздывания дробной рациональной функцией
разложения в ряд Паде. Обычно ограничиваются порядком n =1-3, редко выше, но не
больше 10. Для n = 1
e s τ 
1  0.5 sτ
,
1  0.5 sτ
для n = 2
e
s τ
1  0.5 τs  0.83 τ 2 s 2

.
1  0.5τs  0.83 τ 2 s 2
Синтаксис команды таков:
rsys = pade(sys,n)
.
Для систем с несколькими входами и различными запаздываниями, например,
sys = ss(-1,[1 2],1,[2 0],'inputdelay',[0.1 0.3])
можно указать разный порядок аппроксимации n1 и n2 для каждого входа
rsys = pade(sys,[n1 n2])
.
 Преобразование непрерывных и дискретных моделей
Функция c2d производит дискретизацию непрерывной модели, а функция d2c,
наоборот, преобразует дискретную модель в непрерывную. Эти команды
поддерживают несколько видов квантования/восстановления: восстановление
нулевого порядка (ZOH - Zero-Order Hold), восстановление первого порядка(FOH First-Order Hold), аппроксимацию Тастина без и с предварительной модификацией
частот, с согласованием полюсов и нулей. Синтаксис этих команд (с ZOH по
умолчанию) таков
sysd = c2d(sysc,Ts) % Ts - период квантования или выборки в секундах
sysc = d2c(sysd)
.
Для задания других методов преобразования следует их указать дополнительно:
sysd = c2d(sysc,Ts,'foh')
% использует FOH метод
sysc = d2c(sysd,'tustin')
% использует аппроксимацию Тастина
Дискретная функция по методу ZOH Hd(z) получается из непрерывной функции
H(s) по следующей схеме
Устройство ZOH генерирует непрерывный входной сигнал u(t), удерживая
постоянным значение каждой выборки u[k] в течение одного периода квантования,
т.е.
u(t )  u[k ],
kTs  t  (k  1)Ts .
Сигнал u(t) затем подается на непрерывную систему H(s) и выходной сигнал y(t)
квантуется каждые T s секунд, чтобы получить дискретный выходной сигнал y[k].
Команда d2c, наоборот, из дискретной функции Hd(z) создает непрерывную
функцию H(s), дискретное ZOH преобразование которой совпадает с Hd(z). Эта
обратная операция имеет свои ограничения:
 d2c с ZOH преобразованием не может оперировать с системами с полюсами z =
0;
 действительные отрицательные полюса в z-области отображаются в два
комплексных полюса в s-области, что ведет к увеличению порядка
непрерывной системы.
 Метод FOH
Восстановление по методу FOH отличается от ZOH только механизмом: FOH
использует линейную интерполяцию между моментами квантования
u( t )  u[k ] 
t  kTs
u[k  1]  u[k ],
Ts
kTs  t  ( k  1) Ts .
Такая схема более точна при гладких входных сигналах. Она доступна только
команды c2d. Данный метод FOH отличается от стандартного преобразования FOH
и часто более точно называется треугольной аппроксимацией.
 Аппроксимация Тастина
Аппроксимация Тастина (Tustin) или билинейная аппроксимация использует
выражение
z  e sTs 
1  sTs / 2
1  sTs / 2
для связи передаточных функций в s- области и z- области. В c2d преобразовании
дискретизация Hd(z) непрерывной передаточной функции H(s) получается из
выражения
H d ( z )  H ( s ) ,
s 
2 z 1
.
Ts z  1
Аналогично, d2c преобразование основано на обратном соответствии:
H ( s )  H d ( z ) ,
z 
1  sTs / 2
.
1  sTs / 2
 Аппроксимация Тастина с модификацией частот
Эта вариация аппроксимации Тастина и она использует выражение
H d ( z )  H ( s ) ,
s 
ω
z 1
tan( ωTs / 2) z  1
для обеспечения соответствия между непрерывным и дискретным частотным
откликом на частоте  :
H ( j ω)  H d (e j ωTs ) .
 Дискретизация систем с запаздыванием
Функция c2d может также квантовать непрерывные системы с запаздыванием,
однако при этом использует только методы ZOH и FOH. Так, для дискретизации
системы с ПФ
H ( s )  e 0.25s
10
s 2  3 s  10
наберите
h = tf(10,[1 3 10],'inputdelay',0.25)
hd = c2d(h,0.1)
MATLAB ответит
Transfer function:
0.01187 z^2 + 0.06408 z + 0.009721
z^(-2) * ---------------------------------------------z^3 - 1.655 z^2 + 0.7408 z
Sampling time: 0.1
Полученная модель hd будет свободна от запаздывания. Для сравнения отклика
непрерывной и дискретной моделей наберите команду
step(h,'--',hd,'-') .
MATLAB построит график, показанный ниже.
Изменение частоты квантования
Дискретную LTI систему sys1 можно подвергнуть квантованию с другой частотой,
используя команду
sys2 = d2d(sys1,Ts)
Новая период выборки Ts не должен отличаться в целое число раз от прежнего
значения. Так, строка
h1 = tf([1 0.4],[1 -0.7],0.1)
создает ответ
Transfer function:
z + 1.754
--------z – 0.41
Sampling time: 0.1
Напечатав
h2 = d2d(h1,0.25)
step(h1,'r',h2,'b') ,
изменим начальный период выборки 0,1 с в два с половиной раза.
График отклика системы на ступенчатое воздействие при этих частотах
квантования, построенный MATLAB, приведен ниже. Из него видно, что с
уменьшение периода выборки и увеличения частоты квантования отклик
дискретной системы приближается к своему аналогу для непрерывной системы.
Для снятия точных значений точек графика достаточно щелкнуть мышкой левой
кнопкой мышки на интересующей вас точке и MATLAB выведет название системы,
значения по осям ординат и абсцисс (в данном случае – значения времени и
амплитуды сигнала отклика системы).
Для создания дополнительных текстовых поясняющих надписей на графиках,
редактирования толщины и стиля линий, шрифтов можно использовать
специальный редактор, который вызывается выбором опции Edit Plot в меню Tools
(Инструменты), опций Arrow, Line, Text, Title, Legend и других в меню Insert
(Вставка).
Для ускорения доступа к этим опциям на панели графика имеются кнопки Edit
Plot, Insert Arrow, Insert Line, Insert Text. В режиме Edit Plot необходимо щелкнуть
левой кнопкой мыши по нужному элементу и он становится доступным для
редактирования. Поэкспериментируйте с этими средствами самостоятельно на
графике.
 Обратная связь
Для создания отрицательной обратной связи двух моделей sys1 и sys2 используют
команду
sys = feedback(sys1,sys2, -1) или эквивалентную sys = feedback(sys1, sys2) ;
Для создания положительной обратной связи этих моделей используют команду
sys = feedback(sys1,sys2, +1) .
Для SS моделей опцией feedin указывают какие входы модели sys2 подключены к
входам модели sys1, опцией feedout - какие выходы модели sys2 подключены к входам
sys1. Так, для создания системы
соединим объект управления с входной величиной torque (момент) и выходной
величиной velocity (скорость)
2s 2  5s  1
G( s)  2
s  2s  3
с контроллером в обратной связи
H ( s) 
5( s  2)
,
s  10
используем команды
G = tf([2 5 1],[1 2 3],'inputname','torque','outputname','velocity');
H = zpk(-2,-10,5)
Cloop = feedback(G,H)
MATLAB ответит
Zero/pole/gain from input "torque" to output "velocity":
0.18182 (s+10) (s+2.281) (s+0.2192)
---------------------------------------------(s+3.419) (s^2 + 1.763s + 1.064)
В результате получаем ZPK модель Cloop в соответствии с правилами
предпочтения SS > ZPK > TF. Функция Cloop унаследовала наименования входной и
выходной величин модели от функции G.
Для создания сложных обратных связей используют команды:
star
- для соединения блоков по схеме “звезда”;
series
- для последовательного соединения блоков;
parallel
- для параллельного соединения блоков;
connect
- для получения SS модели по блочной диаграмме.
Однако для построения сложных моделей лучше использовать Simulink.
 Исследование динамики системы
Пакет Control Toolbox имеет команды для определения нулей и полюсов системы,
усиления в области низких частот (на постоянном токе) и т.д.
covar
ковариация отклика на белый шум
damp
собственная частота и коэффициент демпфирования
dcgain
усиление на низкой частоте (постоянном токе)
dsort
ранжирование полюсов и нулей дискретной системы в
порядке убывания их модулей
esort
ранжирование полюсов и нулей непрерывной системы в
порядке убывания их действительных частей
norm
нормы LTI моделей (H2 и L)
pole, eig
полюса системы
pzmap
карта полюсов/нулей
tzero
нули системы
Пример использования этих команд для анализа системы
h = tf([4 8.4 30.8 60],[1 4.12 17.4 30.8 60])
Transfer function:
4 s^3 + 8.4 s^2 + 30.8 s + 60
--------------------------------------s^4 + 4.12 s^3 + 17.4 s^2 + 30.8 s + 60
pole(h)
ans =
-1.7971 + 2.2137i
-1.7971 - 2.2137i
-0.2629 + 2.7039i
-0.2629 - 2.7039i
tzero(h)
ans =
-0.0500 + 2.7382i
-0.0500 - 2.7382i
-2.0000
dcgain(h)
ans =
1
[ninf,fpeak] = norm(h,inf)
% peak gain of freq. response
ninf =
1.3402
% peak gain
fpeak =
1.8537
% frequency where gain peaks
Для анализа SS моделей используют следующие команды
canon
каноническая SS реализация
ctrb
матрица управляемости
ctrbf
матрица управляемости в лестничной форме
gram
граммианы управляемости и наблюдаемости
obsv
матрица наблюдаемости
obsvf
матрица наблюдаемости в лестничной форме
ss2ss
линейное преобразование переменных состояния
ssbal
масштабирование с помощью диагональной матрицы
Функция ssbal использует простую диагональную трансформацию
(A, B, C)  (T-1AT, T-1B, CT)
для сбалансирования SS данных (A, B, C, D) , т.е. для понижения нормы матрицы
T 1 AT T 1 B 

.
0 
 CT
Это улучшает вычисления в SS моделях. Каноническая реализация, даваемая
командами canon, ctrbf, obsvf часто плохо обусловлена, очень чувствительна к
колебаниям значениям данных и мало пригодна для расчета SS моделей. Поэтому их
используют для целей анализа, но не для составления алгоритмов расчета систем
управления.
 Отклик системы во временной и частотной областях
Пакет Control System содержит ряд команд для временного и частотного анализа,
необходимых для проектирования СУ.
Временной отклик
Он описывает переходные процессы (ПП) в LTI системах во времени при
воздействиях на входе и возмущениях на входе. Для этого используются следующие
команды:
step
реакция на ступенчатое воздействие
impulse
реакция на импульсное воздействие
gensig
генерация входных сигналов
lsim
реакция на произвольное заданное воздействие
initial
реакция на ненулевые начальные условия
Функции step, impulse, initial автоматически выбирают пределы по оси абсцисс
для построения ПП. Их синтаксис таков:
step(sys)
impulse(sys)
initial(sys,x0) % x0 – вектор начальных значений переменных состояния.
Для MIMO систем эти команды строят несколько графиков, по одному на
каждый канал входа/выхода.
Так, строка
h = [tf(10,[1 2 10]) , tf(1,[1 1])]
step(h)
строит два графика
Step Response
From: In(2)
From: In(1)
1.4
1.2
Amplitude
1
0.8
0.6
0.4
0.2
0
0
2
4
6 0
2
4
6
Time (sec)
Автоматический режим выбора пределов времени на графиках можно отменить,
задав конечное значение времени:
step(sys,10)
% simulates from 0 to 10 seconds
или вектор равномерно распределенных значений времени отсчета:
t = 0:0.01:10
% отсчет осуществляется каждые 0.01 секунд
step(sys,t)
Функция lsim строит отклик системы для более широкого класса входных
воздействий. Так, команда
t = 0:0.01:10;
u = sin(t);
lsim(sys,u,t)
рассчитывает отклик LTI модели sys на синусоидальное воздействие в течение 10
секунд.
Частотный отклик
Он позволяет исследовать поведение LTI модели в частотной области и
определить полосу пропускания, резонансную частоту, коэффициент усиления на
постоянном токе, АЧХ и ФЧХ, устойчивость замкнутой системы. Для этого
используют следующие команды:
bode
nyquist
nichols
ngrid
evalfr
freqresp
margin
sigma
диаграмма Боде - ЛАЧХ и ЛФЧХ
частотный годограф Найквиста - АФХ
частотный годограф Никольса - АФХ в угловых координатах
линии сетки для диаграммы Никольса
частотная характеристика на заданной частоте
частотная характеристика в заданном диапазоне частот
запас устойчивости по фазе и модулю
частотные характеристики сингулярных значений ПФ
В этих командах диапазон частот выбирается автоматически в зависимости от
расположения нулей и полюсов системы. Для задания частотной области точно в
интервале {wmin, wmax} используют такой синтаксис команд
bode(sys,{wmin , wmax})
% обратите внимание на фигурные скобки
рисует диаграмму Боде в диапазоне частот от 0.1 до 100 рад/с. Можно также задать
вектор интересующих частот. Например,
w = logspace(-1,2,100)
bode(sys,w) .
Команда logspace задает вектор w логарифмически распределенных частот,
начиная с 10-1 = 0,1 рад/с и заканчивая 102 =100 рад/с , всего 100 точек.
 Построение графиков откликов нескольких систем
Для того, чтобы построить отклики нескольких систем на одном графике,
набирают необходимую функцию с входным перечнем исследуемых моделей sys1, ...,
sysN:
step(sys1,sys2,...,sysN)
impulse(sys1,sys2,...,sysN)
...........
bode(sys1,sys2,...,sysN)
nichols(sys1,sys2,...,sysN)
Все модели должны иметь одинаковое число входов и выходов. Для облегчения
восприятия графиков можно задать цвет/стиль линии/маркер (color/linestyle/marker)
для каждой модели так же, как и в предыдущих командах - перечислением. Так,
команда
bode(sys1,’r’,sys2,’y--’,sys3,’gx’)
строит график для sys1 непрерывными красными (r - red) линиями, для sys2 желтыми (y - yellow) пунктирными линиями, для sys3 - зелеными (g - green) линиями
с х маркерами. Можно также задавать и другие цвета, маркеры, толщину линий и
т.п.
 Изменение графиков
Данные откликов системы в частотной или временной областях можно сохранить
в массивах MATLAB командами с левосторонним синтаксисом:
[y,t] = step(sys)
% значение, время
[mag,phase,w] = bode(sys)
% амплитуда, фаза, частота
[re,im,w] = nyquist(sys)
% реальная, мнимая часть, частота.
Сохраненные данные можно использовать для построения графиков в удобном
для пользователя виде. Так, следующий набор команд строит диаграмму Боде,
переходную характеристику и карту расположения полюсов/нулей в одном
графическом окне:
h = tf([4 8.4 30.8 60],[1 4.12 17.4 30.8 60])
Bode Magnitude (dB)
Step Response
[mag,phase,w] = bode(h)
10
1.5
[y,t] = step(h,15)
0
1
[p,z] = pzmap(h)
-10
% Bode Plot
0.5
subplot(221)
-20
semilogx(w,20*log10(mag(:))), grid on
-30
0
0
5
10
15
20
10
10
10
title('Bode Magnitude (dB)')
Bode Phase (deg)
Pole-Zero Map
subplot(223)
50
4
semilogx(w,phase(:)), grid on
2
title('Bode Phase (deg)')
0
0
% Step response
-50
subplot(222)
-2
plot(t,y)
-100
-4
-2
-1.5
-1
-0.5
0
title('Step Response')
10
10
10
% Pole/zero map
subplot(224)
plot(z,'go'), hold, plot(p,'bx')
title('Pole-Zero Map')
Замените в представленном перечне команд в строках, начинающихся со слова
title (наименование), англоязычные термины их русскими эквивалентами Амплитуда, Фаза, Переходная х-ка, Карта полюсов /нулей. При вводе команд
MATLAB построит следующие графики в одном окне:
 Понижение порядка модели
-2
0
2
-2
0
2
Это осуществляется следующими командами
balreal
сбалансированная реализация
minreal
минимальная реализация или сокращение полюсов/нулей
modred
понижение порядка модели или сокращение SS переменных
Обычно вначале используют команду minreal для удаления неуправляемых или
ненаблюдаемых переменных в SS моделях или сокращения полюсов/нулей в TF и
ZPK моделях. Затем для дальнейшего понижения порядка моделей используют две
другие команды balreal и modred.
 LTI Viewer
LTI Viewer является графическим интерфейсом пользователя (GUI),
облегчающим работу с пакетом Control System. Он вызывается командой
.
При этом появляется пустое окно LTI Viewer. LTI Viewer оперирует в свое
собственной рабочей области , которая непосредственно связана с командным окном
MATLAB, но полностью независима от него.
Для импорта в LTI Viewer моделей систем необходимо выбрать опцию Import в
меню File. В появившемся окне браузера будут представлены все модели систем,
находящиеся в рабочем окне MATLAB. Для анализа характеристик интересующих
систем необходимо выбрать их модели и нажать кнопку ОК.
Для выбора нескольких моделей из списка необходимо удерживать нажатой
клавишу Ctrl, поочередно нажимая левой кнопкой мыши на их названиях. При
выборе нескольких моделей, расположенных в списке друг за другом можно
использовать клавишу Shift клавиатуры и левую кнопку мыши
При нажатии кнопки ОК в окне LTI Viewer появляются графики отклика
системы на ступенчатое воздействие (команда Step) для выбранных систем.
Выбор типа отклика из числа известных функций Control System Toolbox - Step,
Impulse, Bode, Bode Mag, Nyquist, Nichols, Sigma, Pole/Zero осуществляется в
ниспадающем меню при нажатии правой кнопки мыши в области окна LTI Viewer и
выборе опции с надписью Plot Type.
Выбор характерных точек на графиках осуществляется пометкой
соответствующих опций с выделенной надписью Characteristics. Набор этих точек
зависит от типа графика. Так, для графика отклика системы на ступенчатое
воздействие ( команда Step) таковыми являются Peak Response (Максимальное
значение), Setting Time (Время установления, или время регулирования), Rise Time
(Время нарастания – от 0,1 до 0,9 установившегося значения), Steady State
(Установившееся значение).
Опция Grid в ниспадающем меню при нажатии правой кнопки мыши в области
окна LTI Viewer создает на графике координатную сетку. Выбор опции Properties
(Свойства) приводит к появлению редактора свойств Property Editor
соответствующего графика отклика системы. Ниже показано окно редактора свойств
для отклика на ступенчатое воздействие Step.
В закладке Labels можно изменять заголовок (Title) и наименование осей (X-Label,
Y-Label) графика.
В закладке Limits задаются пределы изменения по осям X и Y, в закладке Units –
единицы измерения, в закладке Style – размер и стиль шрифта заголовка,
наименования осей X , Y и входов/выходов.
В закладке Characteristics задаются показываемые на графиках характерные
точки и численные значения для их определения. Для графика отклика на
ступенчатое воздействие Step, показанного ниже – это границы для времени
нарастания (10 % и 90 %), значение допустимого отклонения (2 %) для времени
Регулирования.
.
При необходимости показа нескольких графиков различных типов следует
переконфигурировать LTI Viewer, выбрав в меню Edit опцию Plot Configuration.
В появившемся окне можно выбрать конфигурацию представления графиков (с
одним, двумя и т.д., до шести графиков), тип графика, показываемого в каждом окне.
Выбор типа графика осуществляется в ниспадающем меню. Всего возможен
вывод восьми основных типов графиков:
• Step – переходная характеристика;
• Impulse – импульсная переходная характеристика;
• Bode (magnitude and phase) – амплитуда (АЧХ) и фаза (ФЧХ);
• Bode Magnitude – только амплитуда (АЧХ);
• Nyquist – АФХ;
• Nichols – АФХ в угловых координатах;
• Sigma –график собственных значений в зависимости от частоты,
для одномерных моделей совпадает с АЧХ;
• Pole/zero – расположение нулей/полюсов.
Дополнительную информацию из графиков можно получить следующим образом:
при нажатии левой кнопки мыши на какой-либо точке графика показывается
название LTI модели, имя канала ввода/вывода, точное значение отклика
(амплитуда и /или фаза) в этой точке и время или частота.
При щелчке мышью на новой точке выводится информация и для этой точки.
При непрерывном перемещении мышью маркера точки на графике постоянно
отображаются данные для нее. При щелчке правой кнопкой мыши на маркере точке
появляется дополнительное меню для изменения размера шрифта, изменения
местоположения блока с текстовой информацией, включения или отключения
интерполяции между точками графика, удаления выводимой информации.
Практическое задание
1. По данным табл. 1 в соответствии с номером варианта создайте две TF модели
статического объекта регулирования второго порядка h1 и h2- без запаздывания и с
запаздыванием tau с помощью команды tf. Затем преобразуйте их в ZPK и SS
модели zh1, zh2 и ssh1, ssh2. Для определения знаменателя tf команды используйте
функцию conv(den1,den2).
2. Командами step, impulse, bode, nyquist, nichols поочередно постройте отклики
объектов в частотной и временной областях на одном графике. Убедитесь, что
отклики различных форматов моделей идентичны.
3. Командой c2d преобразуйте непрерывные модели h1 и h2 в дискретные dh1, dh2 с
периодом квантования Ts и постройте для них отклики объектов в частотной и
временной областях на одном графике.
4. Измените значения периода квантования и командой d2d для dh1 или c2d для h2,
создайте новые дискретные модели ddh1, ddh2 с меньшим периодом квантования Ts
и постройте для всех четырех дискретных моделей командой step отклик моделей на
одном графике.
5. Командой pade выполните преобразование TF модели объекта с запаздыванием,
обозначив ее h3 .
6. По параметрам объекта для типового переходного процесса с 20%-м
перерегулированием выберите настройки ПИ- и ПИД-регулятора для объекта с
запаздыванием, создайте для них TF модели с обозначениями g1 и g2.
Ориентировочные значения параметров настройки регулятора взять из табл. 2.
7. Создайте модели разомкнутой САР oh1, oh2, в которые входят модели h1, h3 и g1, g2,
и постройте их отклики в частотной и временной областях на одном графике.
8. Командой feedback создайте модели замкнутой непрерывной САР clh1, clh2, в
которые входят модели h1, h3 и g1, g2.
9. Затем командой zpk преобразуйте модель clh2 в zllh2 .
10. Командами step, impulse, bode, nyquist, nichols постройте отклики замкнутых САР
clh1 и zllh2 в частотной и временной областях на одном графике. Если модель с
запаздыванием zclh2 дает расходящийся переходной процесс, измените настройки
регулятора g2.
11. Скопируйте все содержимое рабочего окна MATLAB в свой отчет в формате
документа Word. Скопируйте в отчет графики переходных процессов по команде step
или impulse замкнутых САР.
12. Командой ltiview вызовите LTI Viewer MATLAB. Импортируйте в LTI Viewer по
очереди (лучше парами) функции h1, h2; zh1, zh2; ssh1, ssh2; oh1, oh2; clh1, clh2,
нажмите кнопку Select. В меню Edit, Plot Configuration окне выберите по очереди
опции Step, Impulse, Bode, Nyquist, Pole-Zero. Повторите этот выбор, использую меню,
появляющееся при нажатии правой кнопки мыши на графике. В режиме Step в меню
Characteristics выберите по очереди Peak Response (Максимальное значение), Setting
Time (Время регулирования) , Rise Time (Время разгона), Steady State
(Установившееся состояние). Нажатием левой кнопок мыши на точках графиков
прочитайте значения амплитуды и времени или частоты. Определите значения
характерных точек и для других типов графиков.
13. Результаты своей работы сохраните в файле в своей папке на сервере.
Таблица 1
№ варианта
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Параметры объекта регулирования
Kоб
T1об, с
T2об, с
об, с
0,9
1,1
52
35
6
2,7
0,75
0,8
2,4
0,12
1,6
0,32
1,8
54
61
2,3
0,6
1,2
51
33
6,5
3,0
0,7
0,9
2,2
6,1
2,5
0,6
1,4
54
2,4
23
55
21
62
23
14
35
17
19,5
31
17
37
64
21
8
3,1
22
58
23
64
25
15
3,7
17,6
6
8,4
5,1
25
55
0,8
7
17
7
18
10
5
11
6,3
4,7
9,6
4,3
10
22
7,4
2,7
1,2
6,8
15
8
17
11
6,1
1,3
7,3
1,4
2,6
1,2
6,8
13
0,3
2
5
3
7
3
1,2
2,3
1,5
2,2
1
1,5
1,6
2,5
1,2
1,5
1,2
1,2
2,4
1,5
4
2
1,3
0,4
1,8
0,2
0,5
0,4
0,8
2,4
Таблица 2
Оптимальные параметры настройки регуляторов для статических
объектов первого порядка с запаздыванием
Тип
Параметры
регулятора
настройки
Тип переходного процесса
апериодический
с 20%-м
перерегулированием
с min

y2 dt
ИП-
Кр
1/(4,5 A) *
1/(1,7A)
1/(1,7 A)
Кр
0,3 В *
0,7 В
0,9 В
Кр
0,6 В
0,7 В
1,0 В
ПИТи
0,6 Тоб
0,7 Тоб
1,0 Тоб
Кр
0,95 В
1,2 В
1,4 В
ПИДТи
2,4 об
2,0 об
1,3 об
Тд
0,4 об
0,4 об
0,5 об
 Примечание: А = КобТоб; В = Тоб/(Кобоб).
Поскольку ОР в задании имеет второй, а не первый порядок как в таблице 2, то
вычисленные параметры настройки регулятора являются весьма приближенными.
Для определения параметров настройки регуляторов в качестве Тоб в таблице 2 для
ОР второго порядка следует брать сумму значений T1об и T2об в таблице 1. Сами
параметры настройки регуляторов следует уточнить в ходе ручного изменения в
командной строке MATLAB.
Контрольные вопросы для защиты
1. Команды создания непрерывных LTI моделей.
2. Команды создания дискретных LTI моделей.
3. Извлечение данных и преобразование форматов моделей.
4. Операции над LTI моделями.
5. Преобразование непрерывных и дискретных моделей.
6. Учет запаздывания.
7. Изменение частоты квантования.
8. Создание систем с обратной связью.
9. Команды анализа TF и ZPK моделей.
10. Команды анализа SS моделей.
11. Построение SS моделей по матрицам A, B, C, D, выдаваемых MATLAB.
12. Построение отклика во временной области.
13. Построение отклика в частотной области.
14. Построение графиков откликов нескольких систем.
15. Понижение порядка модели.
16. Порядок работы с LTI Viewer.
Литература
1. Медведев В.С., Потемкин В.Г. Control Systems Toolbox. MATLAB 5 для
студентов. – М.: Диалог – МИФИ, 1999. – 287 с.
Скачать