Базой данных

Реклама
МОУ "Гимназия №7 г. Брянска
имени Героя России С.В. Василёва"
Научная работа по информатике
«Использование баз данных и
СУБД для обработки экономической информации»
Подготовила
ученица 11 «Б» класса
Коротке Юлия
Руководитель Петроченко В. И.
Брянск 2010
Содержание
Глава 1. Базы данных и СУБД:
• Понятие банка данных, базы данных и СУБД;
• Функции СУБД;
• Модели данных, поддерживаемые СУБД;
• Типы информационных сетей;
• Области применения баз данных в экономике;
Глава 2.
Обзор наиболее популярных СУБД:
• Microsoft Access;
• Visual FoxPro
Выводы и предложения
Список использованной литературы
Понятие банка данных, базы данных и СУБД
Банк Данных — организованная, определенным образом упорядоченная совокупность данных, свод экономической информации, приспособленной для коллективного использования многими потребителями. В состав банка данных входят одна или несколько баз данных, справочник баз
данных, СУБД, а также библиотеки запросов и прикладных
программ.
Базой данных является представленная в объективной
форме совокупность самостоятельных материалов (статей,
расчетов, нормативных актов, судебных решений и иных
подобных материалов), систематизированных таким образом, чтобы эти материалы могли быть найдены и обработаны с помощью электронной вычислительной машины.
Базой данных часто ошибочно называют систему управления базами данных. Необходимо различать хранимые
данные и программное обеспечение, предназначенное для
организации и ведения базы данных (СУБД)
Программное обеспечение, позволяющее работать с
базой данных, называется Системой Управления Базами
Данных (СУБД)
Функции СУБД
• определения данных (СУБД должна допускать определения
данных (внешние схемы, концептуальную схему, внутреннюю
схему, а также все связанные отображения) в исходной форме
и преобразовывать эти определения в форму соответствующих объектов)
•
обработка данных (СУБД должна уметь обрабатывать запросы пользователя на выборку, изменение или удаление соответствующих данных в базе данных или на добавление новых
данных в базу данных)
•
безопасность и целостность данных (СУБД должна контролировать пользовательские запросы и пресекать попытки
нарушения правил безопасности и целостности, определенных
АБД)
•
восстановление данных и дублирование (восстановление и
дублирование данных осуществляется СУБД или администратором)
•
введение словаря данных (словарь данных – это исчерпывающий набор таблиц или файлов, представляющий собой каталог всех описаний данных). Словарь данных является центральным источником информации для СУБД, АБД всех
пользователей
•
производительность (СУБД должна выполнять все указанные функции с максимально возможной эффективностью)
Модели данных, поддерживаемые СУБД
Многообразие характеристик и видов баз данных порождает многообразие
классификации СУБД
Прежде чем создавать базу данных, с которой вам придется работать, необходимо выбрать модель данных, наиболее удобную для решения поставленной задачи. (Модель данных – совокупность структур данных и операций их
обработки.)
С помощью модели данных могут быть представлены объекты предметной
области и взаимосвязи между ними. Модели данных, которые поддерживают
СУБД, а, следовательно, и сами СУБД делят на:
• иерархические
•
сетевые
•
реляционные
Иерархическая модель данных
Иерархическая модель данных состоит из нескольких записей, одна из которых определена как корневая. Примером иерархической модели могут
служить деревья (многоуровневые структуры). Информация упорядочена
так, что один элемент записи считается главным, остальные-подчиненными.
Сетевая модель данных
Сетевая модель данных подобна иерархической, но является более общей
моделью (в ней нет корневого узла, т. е. любая запись может быть корневой).
К основным понятиям сетевой модели данных относятся: уровень, элемент
(узел), связь. (Узел — это совокупность атрибутов данных, описывающих
некоторый объект.) На схеме иерархического дерева узлы представляются
вершинами графа. В сетевой структуре каждый элемент может быть связан с
любым другим элементом.
Реляционная модель данных
Реляционная модель данных представляет собой данные, упорядоченные в таблицы, чаще всего двухмерные. Таблицы такого вида
называются отношениями (реляциями) и каждая таблица представляет собой отдельный файл.
Типы информационных сетей
1. Локальные ИС
БД и СУБД находятся на одном компьютере.
2. Файл-серверные
БД находится на сервере сети (файловом сервере), а СУБД
на компьютере пользователя.
3. Клиент-серверные
БД
и основная СУБД находятся на сервере,
СУБД на рабочей станции посылает запрос
и выводит на экран результат.
Локальные ИС
- автономность (независимость)
- с БД работает только один человек
- сложно обновлять при большом количестве пользователей
- практически невозможно «стыковать» изменения, вносимые несколькими пользователями
Файл-серверные ИС
- несколько человек работают с одной базой
- основную работу выполняют рабочие станции(РС),
они должны быть мощными
- для поиска строки на РС копируется вся БД – нагрузка на сеть
- слабая защита от взлома (только на РС)
- проблемы при одновременном изменении с разных РС
Клиент-серверные ИС
- основную работу выполняет сервер
- проще модернизация (только сервер)
- по сети идут только нужные данные
- сложность настройки
Области применения БД в экономике
Автоматизированные информационные системы (АИС), основу которых составляют базы данных, появились в 60-х годах в военной
промышленности и в бизнесе – там, где были накоплены значительные объемы полезных данных. Первоначально автоматизированные информационные системы были ориентированы лишь на
работу с информацией фактического характера – числовыми или
текстовыми характеристиками объектов. Затем, по мере развития
техники, появилась возможность обрабатывать текстовую информацию на естественном языке.
Принципы хранения разных видов информации в АИС сходны, но
алгоритмы ее обработки определяются характером информационных ресурсов. Соответственно были выделены два класса АИС:
•
документальные
•
фактографические
Документальные АИС
Документальные АИС служат для работы с документами на естественном языке. Наиболее распространенный тип документальной
АИС – информационно-поисковые системы, предназначенные для
накопления и подбора документов, удовлетворяющих заданным
критериям.
В документальных БД содержатся документы ( информация)
самого разного типа: текстового, графического, звукового, мультемедийного (например, различные справочники, словари)
Примерами документальных Баз Данных являются:
•
БД законодательных актов в области уголовного права
•
БД современной рок-музыки
Фактографические АИС
Фактографические АИС оперируют фактическими сведениями,
представленными в формализованном виде. Фактографические
АИС используют для решения задач обработки данных. Задачи этого класса решаются при учете товаров в магазинах и на складах,
начислении заработной платы, управлении производством, финансами, телекоммуникациями.
Различают фактографические АИС оперативной обработки данных,
подразумевающие быстрое обслуживание относительно простых
запросов от большого числа пользователей, и фактографические
АИС аналитической обработки, ориентированные на выполнение
сложных запросов.
Примерами фактографических Баз Данных являются:
•
БД книжного фонда библиотеки
•
БД кадрового состава учреждения
Microsoft Access
Наиболее используемые из существующих СУБД: Oracle, DB2, MS SQL
Server, FoxPro, MS Access, Interbase, Sybase и другие.
MS Access - на сегодняшний день лучшая настольная система управления базами данных для ОС Windows.
Она предназначена для хранения и поиска данных, представления информации в удобном виде и автоматизации часто повторяющихся операций.
Access также предоставляет в распоряжение пользователя механизмы работы
с базами данных различных форматов. К примеру, можно прямо обращаться
к базам данных dBASE, Paradox или Btrieve без конвертирования их в формат, используемый Access. В состав пакета Access также входит язык Access
Basic (встроенный диалект языка Visual Basic), дающий возможность формирования специализированных систем управления базами данных.
Объекты MS Access
Таблицы — основные объекты базы данных. Запросы — это специальные
структуры, предназначенные для обработки данных базы . Формы — это
объекты, с помощью которых в базу вводят новые данные или просматривают имеющиеся. Отчеты — это формы «наоборот»,
С их помощью данные выдают на принтер в удобном и наглядном виде.
Макросы — это макрокоманды. Модули — это программные процедуры,
написанные на языке Visual Basic.
Реляционная СУБД Access
Реляционная СУБД Access предусматривает хранение данных во множестве
связанных таблиц, которые снабжены средствами проверки допустимости
данных, предотвращающими некорректный ввод.
Таблицы в БД
Таблица – это структура для хранения данных. Информация в таблицах организована в виде записей (строк) и полей (столбцов).
Создание таблицы
Создание таблицы – это определение имени и типа данных для каждого из
полей. В MS Access для представления информации используются следующие типы данных:
- текстовый
- счетчик
- поле МЕМО
- логический
- числовой
- поле объекта ОЛЕ
- дата/время
- гиперссылка
- денежный
- мастер подстановок
Типы данных Microsoft Access
Текстовый
Алфавитно-цифровые символы
0 – 255 символов
Поле МЕМО
Алфавитно-цифровые символы
0 – 64000
символов
Числовой
Числовые значения
1, 2, 4 или 8
байт
Дата/время
Дата и время
8 байт
Денежный
Денежные значения
8 байт
Счетчик
Автоматически увеличивающиеся номера
4 байта
Логический
Логические значения Да/Нет
1 бит ( 0 или
-1 )
Поле объекта ОЛЕ
Рисунки, диаграммы, звук и видео
До 1 Гбайт
Гиперссылка
Связь с ресурсом Internet
0 – 6144
Мастер подстановок
Данные, подставляемые из другой таблицы
Обычно 4
байта
Ключевое поле
После определения структуры каждой таблицы следует подумать, какое поле
таблицы будет однозначно определять каждую запись.
То есть выбрать ключевое поле.
На панели инструментов есть специальная кнопка:
Создание файла БД в MS Access
Для создания файла базы данных в MS Access в левом нижнем углу Рабочего стола следует нажать кнопку Пуск, чтобы вызвать Главное меню.
Затем из меню Программы выбрать пункт Microsoft Access.
Можно создать и разместить на своем Рабочем столе Ярлык для программы
MS Access
При запуске Access первое, что вы увидите – это диалоговое окно, в котором
следует отметить нужный вам пункт
.
После выбора нажмите кнопку ОК!
В открывшемся окне выберите нужный каталог и задайте имя файла, в котором будет храниться ваша база данных
Нажмите кнопку Создать
В левой части окна открытой базы данных находится список Объектов, в котором выбраны Таблицы.
В правой – способы создания таблиц.
Для начинающих пользователей лучшим способом является Создание таблицы с помощью мастера.
При двойном клике мышкой на этой надписи появляется окно, в котором
можно выбрать образец таблицы и образцы полей. Есть возможность переименовать поля. Перенос полей из образцов в вашу таблицу осуществляется с
помощью кнопок:
В MS Access есть большое количество готовых таблиц для служебного и
личного пользования
Если есть поле, похожее на нужное, но с другим именем, то можно дать ему
новое имя, нажав кнопку «Переименовать поле…»
Имя таблицы и ключевое поле можно задать самостоятельно.
Ввод данных
Когда структура созданной таблицы готова, можно вводить данные, т.е. в
следующем окне выбрать нужный пункт.
Нажмите кнопку Готово
При необходимости срочно ввести большой объем различных данных удобно
использовать Создание таблицы путем ввода данных
Для выполнения различных операций можно использовать контекстное
меню.
Создание таблиц с помощью конструктора
Когда нужная таблица содержит специальные поля, которых нет в распоряжении мастера, используем Создание таблицы в режиме конструктора
С помощью этого режима можно редактировать и готовую таблицу с внесенными данными. Для этого выделите таблицу и щелкните на панели инструментов кнопку
Окно конструктора таблиц состоит из двух областей: области описания полей
и области свойств полей.
Каждая строка описывает одно поле. Внизу справа Access дает подсказки.
Для получения справки нужно выделить объект и нажать клавишу F1.
Выбор типа данных
При выборе типа данных поля Счетчик рекомендуется этому же полю присвоить значение ключевого
Для каждого типа данных в области свойств поля Access предлагает пользователю свои значения.
Свойства полей
Там, где в области свойств поля нет значений, их можно указать самостоятельно. Удобно использовать справку.
Для каждого свойства дается подсказка
Изменение свойств поля
Для изменения стандартных свойств поля следует выделить его и щелкнуть
мышкой на появившемся выпадающем списке, из которого выбрать нужное
значение.
Условие на значение
Свойство Условие на значение определяет требования к данным, вводящимся в поле. Этим условием может быть принадлежность данных какомулибо диапазону либо соответствие введенному выражению.
Чтобы ввести выражение, следует нажать кнопку:
Появится окно Построителя выражений.
Построитель выражений
В этом окне с помощью предлагаемых функций, констант, операторов можно
записать требуемое выражение.
Таким же образом можно создать выражение для свойства Значение по
умолчанию, которое Access будет отображать автоматически для данного
поля при добавлении новой записи в таблицу.
Сохранение таблицы
После создания структуры таблицы следует сохранить ее под выбранным
именем перед вводом данных. Сделать это можно разными способами.
При закрытии окна Конструктора Access предложит сохранить изменения
макета или структуры таблицы. В окне Сохранение по умолчанию предлагается имя Таблица1 (если она первая из созданных), которое можно изменить.
Кроме этого в панели инструментов Стандартная есть кнопка Сохранить.
В меню Файл можно выбрать пункт Сохранить как…
Имя таблицы должно состоять не более чем из 64 символов и удовлетворять
стандартному соглашению об именах, принятому в Access.
Запросы
Таблицы баз данных не являются самостоятельными документами.
Сама база — это документ. Ей соответствует файл на диске, и мы можем
сделать его копию. Структура таблиц — тоже документ.
Все изменения в
реального времени.
таблицах
сохраняются
автоматически
в
Для доступа к данным есть гибкое и удобное средство — запросы
режиме
В режиме Запросы выбирают Создание запроса с помощью Мастера.
В появившемся окне Таблицы и запросы в Доступных полях выбирают
нужную информацию и переносят в
Выбранные поля
и нажимают Далее
В результате работы запроса из общей исходной базы формируется
результирующая таблица, содержащая часть общей информации,
соответствующую запросу. Запрос можно создать и в режиме Конструктора
Формы
Для
упрощения
труда
разработчик
базы
может
подготовить
специальные объекты — формы.
Форма представляет собой
некий электронный бланк, в котором имеются поля для ввода
данных. Наборщик вводит данные в эти поля, и данные
автоматически заносятся в таблицы базы.
Зачем нужны формы?
Данные в таблицу можно вносить и без помощи каких-либо форм,
но существуют по крайней мере четыре причины, которые делают
формы незаменимым средством ввода данных в базу.
1. Малоквалифицированному персоналу нельзя предоставлять доступ
к таблицам (самому ценному из того, что есть в базе).
Представьте, что будет, если новичок «наведет порядок» в таблице
банка
2. Разные люди могут иметь разные права доступа к информации,
хранящейся в таблицах.
3. Ввод данных в таблицу — чрезвычайно утомительное занятие.
Уже после нескольких часов работы люди делают ошибки.
Ввод данных в форму проще. Здесь многое можно автоматизировать.
4. Откуда
берется
информация
для
баз
данных.
Как
правило,
ее
берут
из
бумажных
бланков
(анкет, заявлений, накладных, счетов, описей, ведомостей, справок и
т. п.). Экранные формы можно сделать точной копией бумажных
бланков, с которых происходит ввод данных Благодаря этому но много раз уменьшается количество ошибок при вводе и значительно
снижается утомляемость персонала.
Создание форм в режиме конструктора
Создание форм с помощью мастера
Отчеты
Отчеты во многом похожи на формы и тоже позволяют получить
результаты работы запросов в наглядной форме, но только не на
экране, а в виде распечатки на принтере. Таким образом, в результате работы отчета создается бумажный документ.
Visual FoxPro
Реляционные системы управления базами данных (СУБД), такие как
FoxBase, FoxBase plus, FoxPro, Visual FoxPro относятся к новому поколению
СУБД реляционного типа из семейства dBase – подобных СУБД. Пакеты этого семейства получили широкое распространение, и многие из них были русифицированы.
СУБД типа Fox сохраняет преемственность по отношению к более ранним
представителям dBase – подобных СУБД, в отношении структуры баз данных, команд создания и обработки данных, основных типов данных. В тоже
время каждая последующая СУБД обладает большими возможностями по
сравнению с предыдущими. Так, например, Visual FoxPro по сравнению с
FoxPro обладает более значительными изобразительными возможностями.
База данных в Visual FoxPro – это совокупность таблиц, отношений между
таблицами, индексов, триггеров и хранимых процедур.
Данная работа использует язык команд СУБД семейства Fox. Используемые
команды, в основном, применимы во всех СУБД этого типа, но отладка велась на русифицированной СУБД FoxPro для Windows версии 2.5b.
Создание БД в Visual FoxPro
Создание базы данных в Visual FoxPro осуществляется в интерактивном режиме с помощью конструктора базы данных, который позволяет:
1. Создавать и модифицировать таблицы, хранимые процедуры, представления данных;
2. Добавлять созданные ранее таблицы;
3. Определять для таблиц индексы;
4. Устанавливать отношения между таблицами, которые будут поддерживаться при создании форм и отчетов.
В среде СУБД типа Fox каждая подзадача может оформляться в виде отдельного командного файла с расширением. prg и заканчиваться оператором возврата в вызывающий командный файл.
В данном случае основным командным файлом является файл Main Menu.
prg, который формирует полное экранное меню и осуществляет вызов других
командных файлов, в зависимости от выбранного пункта меню.
CreateFd. prg
– создание файла данных;
ReadFd. prg
– чтение созданного файла данных;
AddFd. prg
– добавление данных в созданный файл данных;
Zad1. prg
– выдача сведений о суммарной стоимости продукции
заданного вида по каждому предприятию и о среднем
выпуске этой продукции одним предприятием;
Zad2. prg
– выдача сведений о суммарной стоимости и суммарном выпуске каждой продукции;
Zad3. prg
– выдача на печать продукции пяти видов в порядке
возрастания ее суммарной стоимости.
Разработка нового приложения
Приступая к разработке нового приложения, прежде всего, создайте проект
приложения. В дальнейшем вы будете добавлять в него созданные вами элементы приложения. Для создания нового проекта вы можете использовать
мастер Application Wizard (Мастер приложения) или команду New (Новый)
из меню File (Файл).
При выполнении команды New (Новый) на экране открывается соответствующее диалоговое окно с перечислением всех типов элементов приложения,
которые возможны в Visual FoxPro. По умолчанию установлена опция Project
(Проект).
Для создания нового проекта необходимо выполнить следующие действия:
1. Нажмите кнопку New File (Новый файл), и на экране
появится следующее диалоговое окно
2. В поле ввода Enter Project (Введите имя проекта) диалогового окна Create (Создать) задайте имя создаваемого
проекта (proj1), убедившись, что в поле Тип файла установлен тип сохраняемого файла Project (Проект), а в поле Папка правильно выбрана папка, в которой вы хотите
расположить свой проект.
3. Для сохранения созданного проекта нажмите кнопку Сохранить.
VisualFoxPro создаст файлы проекта
и запишет их в указанное место. После этого откроется окно проекта
Project Manager (Менеджер проекта):
Создание базы данных в окне проекта
База данных является частью проекта, поэтому ее целесообразно
создавать в окне проекта. Для создания базы данных выполните
следующие действия:
1. Откройте созданный проект.
2. Выберите в верхней части окна конструктора проектов вкладку Data(Данные). Курсор по умолчанию устанавливается в
начале вкладки назначении Databases (Базы данных).
3. Нажмите кнопку New (Новый) в окне проекта.
4. В открывшемся диалоговом окне New Databases (Новая база
данных) нажмите кнопку New Databases (Новая база данных).
5. В поле ввода Enter Databases (Введите имя базы данных) появившегося на экране диалогового окна Create (Создать) задайте имя создаваемой базы данных, убедившись, что в поле
Тип файла установлен тип сохраняемого файла Database (База
данных), а в раскрывающемся списке Папка правильно указана папка, в которой вы хотите расположить создаваемую базу
данных.
Сохранение БД
Для сохранения созданной базы
данных нажмите кнопку Сохранить. После этого откроется пустое окно базы данных Database
Designer (Конструктор базы данных), изображенное ниже. Используя панель инструментов
Designer (Конструктор базы данных), команды меню Database
(База данных) и контекстное меню, в окне конструктора базы
данных вы можете создавать новые таблицы, модифицировать
существующие, создавать для них
индексы, устанавливать отношения между таблицами.
Конструктор баз данных
В начале создания базы данных окно
конструктора базы данных пусто. На
рисунке показано, как выглядит это окно с размещенными в нем таблицами.
Для создания в конструкторе базы данных новых таблиц и модификации существующих вы можете использовать:
• команды меню Database (База
данных);
• команды контекстного меню, появляющегося при нажатии правой кнопки мыши в окне конструктора базы данных;
•
панель инструментов Database Designer (Конструктор базы данных).
Назначение команд меню Database
New Table (Новая таблица)
Создает новую таблицу
Add Table (Добавить таблицу)
Добавляет созданную таблицу в БД
Modify (Модифицировать)
Открывает таблицу в конструкторе
таблиц
Browse (Обзор таблицы)
Показывает содержимое таблицы
Remove (Удалить)
Удаляет таблицу из базы данных
Find Object (Найти объект)
Находит объект в окне конструктора
БД
Rebuild Table Indexes (Перестроить Перестраивает индексы
индексы)
Edit Relationship
Редактирует отношения между таблицами
Edit Referential Integrity
Определяет
данных
Edit Stored Procedures
Открывает окно редактирования процедур
Connections (Соединения)
Создание или модификация соединения с удаленными данными
Arrange (Упорядочить)
Упорядочивает объекты по имени
или типу
Refresh (Обновить)
Обновляет информацию конструктора БД
Properties (Свойства)
Выводит на экран окно свойств БД
условия
целостности
CleanUp Database (Очистка базы дан- Очищает БД от помеченных объектов
ных)
Панель инструментов Database Designer
Панель инструментов Database
Designer (Конструктор базы данных) содержит кнопки для выполнения наиболее часто используемых операций.
Создание БД с помощью мастера
Для создания таблицы с помощью мастера из конструктора базы данных выполните следующие действия:
1. Откройте диалоговое окно New Table
(Новая таблица), выполнив любое из
следующих действий:
•
выберите команду New Table
(Новая таблица) из меню Database
(База данных);
•
выберите команду New Table (Новая таблица) контекстного меню;
•
нажмите кнопку New Table (Новая таблица) на панели инструментов
Database Designer (Конструктор базы данных).
2. В диалоговом окне New Table (Новая таблица) нажмите кнопку Table
Wizard (Мастер таблицы). На экране появляется первое диалоговое окно мастера.
3. Visual FoxPro предлагает целый ряд таблиц, которые вы можете использовать в качестве прототипов, что позволит сэкономить время и обеспечить
стандартные имена и типы данных для полей создаваемой таблицы.
На этом шаге вам необходимо, используя предлагаемые Visual FoxPro прототипы таблиц и их поля, сформировать список полей создаваемой таблицы.
Для этого из списка Sample Tables (Примеры таблиц)выберите таблицу, которую хотите взять за основу при создании своей таблицы. При этом в списке
Available Fields (Имеющиеся поля) отобразятся поля выбранной таблицы.
4.
Перенесите из
списка Available Fields
(Имеющиеся поля) в
список Selected Fields
(Выбранные поля) поля, которые вы хотите
разместить в создаваемой таблице.
Закончив формирование списка полей,
нажмите кнопку Next (Далее).
5. На следующем шаге работы мастера вам необходимо указать, создаете вы
свободную таблицу или данная таблица будет добавлена в базу данных.
Create my table as a stand-alone
free table
Add my table to the following
database
6. В следующем диалоговом окне
мастера можно изменить наименования выбранных полей, их тип
При выборе этой опции создается свободная таблица
Создаваемая таблица будет добавлена в базу данных
и
размеры, используя для этого поля Field Name (Имя поля), Туре (Тип), Width
(Ширина) и Decimals(Десятичные). Можно также, используя поле ввода
Caption (Надпись),задать для каждого поля заголовок, который будет использоваться при просмотре таблицы и в качестве надписи к полю таблицы при
создании форм с помощью мастера.
7. На этом шаге в работе мастера с помощью раскрывающегося списка Primary Key
(Первичный ключ), содержащего список всех полей таблицы, задайте первичный ключ
таблицы. При этом вы должны
помнить, что поле может использоваться для задания первичного ключа таблицы только в том случае, если оно содержит неповторяющиеся значения.
8. Если вы создаете не свободную таблицу, а таблицу, входящую в базу данных, то на следующем шаге мастера определяются связи между новой таблицей и
таблицами базы данных (В списке My new <имя_таблицы> table
диалогового окна содержится перечень всех существующих связей для новой таблицы.) Используя данный список
и диалоговое окно Relationships(Отношения), задайте тип связи между создаваемой таблицей и остальными таблицами базы данных.
9. На последнем шаге работы мастера указывается режим дальнейшей работы с таблицей. Для этого необходимо выбрать одну из трех опций. Выбрав
одну из трех опций, нажмите кнопку Finish (Готово). Таблица создана и, в
зависимости от установленной опции, откроется в режиме Browse (Обзор)
или в конструкторе таблицы для дальнейшей модификации .
Save table for later use
Сохраняет созданную таблицу
Сохраняет таблицу и открывает для просмотра
Save table and browse it
Save table and modify in the Table De- Сохраняет таблицу и открывает в конструкторе
signer
Создание первичного ключа для таблицы
Последовательность действий при
создании первичного ключа для
таблицы (ключ таблицы должен
быть уникальным):
1. Откройте окно конструктора таблицы. Для этого в
окне проекта установите
курсор на модифицируемую
таблицу и нажмите кнопку
Modify (Модифицировать)
конструктора проекта.
2. В окне Table Designer (Конструктор таблицы) перейдите на вкладку
Indexes (Индексы).
3. В поле Name (Имя) введите имя индекса .
4. Из списка возможных типов индекса в поле Туре (Тип) выберите значение Primary (Первичный).
5. Перейдите в поле Expression (Выражение) и введите выражение для
индекса.
6. Установите переключатель столбца Order (Упорядочение) в значение
По возрастанию.
7. Для завершения создания индекса нажмите кнопку ОК.
Целостность данных
Целостность данных является одним из самых важных требований, предъявляемых к базам данных. Для определения условия целостности данных используется окно построителя условий целостности данных Referential
Integrity Builder (Построитель целостности данных) (рис.2.4), которое содержит перечень всех установленных отношений между таблицами. В данной
базе данный не требуется что либо изменять, а нужно оставить все по умолчанию.
Диалоговое окно Referential Integrity Builder (Построитель целостности данных) изображено на рисунке:
Создание формы с помощью мастера
Рассмотрим создание формы с помощью мастера формы Form Wizard (Мастер формы). Он позволяет создавать формы как для одиночных, так и связанных таблиц, а также настраивать поля, стиль их отображения, тип кнопок
управления, размещаемых в форме.
Форму, созданную с помощью мастера, можно использовать для просмотра и
редактирования информации, содержащейся в таблицах Visual FoxPro. Она
содержит в нижней части кнопки для выбора режима просмотра, добавления
и удаления записей, сохранения введенной информации и печати данных.
Для запуска мастера выполните одно из следующих действий.
•
Выберите в меню Tools (Сервис) команду Wizards (Мастера), а затем в
открывшемся меню команды значение Form (Форма).
•
Нажмите кнопку Form Wizard (Мастер формы) в диалоговом окне
NewForm (Новая форма), открываемом при создании новой формы из
окна проекта.
Нажмите кнопку Wizard (Мастер) в диалоговом окне New (Новый), которое
открывается при нажатии кнопки New (Новый) стандартной панели инстру-
ментов или выборе команды New (Новый) из меню File (Файл). Рассмотрим
создание формы с помощью мастера из окна проекта.
1. Откройте базу данных проекта.
Для этого на вкладке Data (Данные)
установите курсор на ее название и
нажмите кнопку Open (Открыть)
окна проекта. При этом на стандартной панели инструментов в
списке Databases (Базы данных) появится название открытой базы данных.
2. Щелкните на ярлыке Documents (Документы) для перехода на вкладку
Documents (Документы) .
3. Выберите группу Forms (Формы) и нажмите кнопку New (Новый) окна
конструктора проекта. Откроется диалоговое окно New Form (Новая форма).
4. Нажмите кнопку Form Wizard (Мастер формы).
5. После запуска мастера форм на экране открывается диалоговое окно
Wizard Selection (Выбор мастера) Значение Form Wizard (Мастер формы) используется для создания однотабличной формы, a One-to-ManyForm Wizard
(Мастер форм один-ко-многим) — для нескольких связанных. По умолчанию
установлено первое значение. Нажмите кнопку ОК для запуска мастера по
созданию однотабличной формы.
6. Появляется первое диалоговое
окно мастера, в котором необходимо указать таблицу, для которой вы создаете форму, и выбрать поля этой таблицы, размещаемые в форме. В области
Databases and tables (Базы данных и таблицы) расположены два списка. В
верхнем списке содержится перечень открытых баз данных, в нижнем — перечень таблиц выбранной базы. Выберите из верхнего списка необходимую
базу данных, а из нижнего — таблицу, для которой создаете форму.
Для выбора базы данных и
входящих в нее таблиц
нажмите кнопку, расположенную рядом со списком
баз данных, и в открывшемся
диалоговом окне Open (Открыть) найдите таблицу, которая будет использоваться
при создании формы.
7. После выбора таблицы
список Available fields (Имеющиеся поля) будет содержать перечень всех полей таблицы. Вам необходимо из данного списка перенести в Selected fields
(Выбранные поля) поля, которые вы хотите разместить в создаваемой форме.
Для переноса полей используйте кнопки, расположенные между списками.
После создания списка полей, отображаемых в форме, нажмите кнопку Next
(Далее) для перехода к следующему шагу.
8. В появившемся диалоговом окне мастера следует установить стиль отображения объектов формы и типы кнопок управления
Переключатель Button type (Тип
кнопки) содержит опции, позволяющие задать тип отображения
размещаемых в форме кнопок
управления.
Text buttons
Кнопки содержат текстовые надписи
Picture buttons
Кнопки содержат графические изображения
No buttons
Кнопки управления в форме отсутствуют
Custom
В форме размещается пять кнопок управления: Find(Поиск),
Print (Печать), Add (Добавить), Delete (Удалить),Exit (Выход)
9. На следующем шаге задается
критерий сортировки данных,
отображаемых в форме
10. На заключительном шаге создания формы с помощью мастера
вы можете задать заголовок формы
в поле Type a title for your form
(Тип заголовка формы), а также
указать предполагаемые действия
с созданной формой, используя опции:
Save form for later use
Созданная форма сохраняется на диске
Save and run form
Созданная форма сохраняется и запускается на выполнение
Save form and modify Созданная форма сохраняется и открывается в конit in the FormDesigner структоре форм
Использование мастера для создания отчета
1. Откройте создаваемый вами проект.
2. Откройте базу данных проекта. Для этого на вкладке Data (Данные) установите курсор на ее названии и нажмите кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы
данных) появится название открытой базы данных.
3. Перейдите на вкладку Documents (Документы) и выберите группу Reports
(Отчеты).
4. Нажмите кнопку New (Новый)
окна проекта .
5. В открывшемся диалоговом окне
New Report (Новый отчет) выберите опцию Report Wizard (Мастер
отчета).
6. После запуска мастера для построения отчета на экране открывается диалоговое окно, в котором вы должны указать тип создаваемого отчета.
One-to-Many Report
Wizard
Создает отчет для таблиц с отношением
"один-ко-многим"
Report Wizard
Создает простой однотабличный отчет
7. Открывается первое диалоговое
окно мастера, в котором необходимо указать таблицу, для которой
вы создаете отчет, и выбрать размещаемые в отчете поля. В области Databases and tables (Базы данных и таблицы) расположены два
списка. Верхний список содержит
открытые базы данных, а нижний
— таблицы выбранной из верхнего списка базы. Выберите из верхнего списка необходимую базу данных, а из нижнего —таблицу, для которой создаете
отчет.
8. После выбора таблицы, для которой создается отчет, список Availablefields
(Имеющиеся поля) будет содержать перечень всех полей таблицы. Вам необходимо из данного перечня перенести в список Selected fields (Выбранные
поля) поля, которые вы хотите разместить в создаваемом отчете.
Для переноса полей используйте располагающиеся между списками кнопки.
После формирования списка отображаемых в отчете полей нажмите кнопку
Next (Далее) для перехода к следующему шагу в создании отчета.
9. В следующем диалоговом
окне мастера создания отчета
необходимо указать поля, по которым будет осуществляться
группировка данных в отчете
10. Для задания интервала группировки
нажмите
кнопку
Grouping options (Опции группировки). Открывается диалоговое окно Grouping Intervals
(Интервалы группировки). Раскрывающийся список Grouping
intervals (Интервалы группировки) этого окна содержит
значения.
Entire
Field
Интервал группировки задается исходя из полного значения поля таблицы
1st Letter
Группировка осуществляется по первой букве значения поля таблицы
2-5
ters
Let- Группировка осуществляется по 2-5первым буквам значения поля
11. Для формирования в отчете итоговых значений воспользуйтесь диалоговым окном Summary Options ( Итоговые опции ). В нем содержится таблица,
строками которой являются поля таблицы, а столбцами - возможные итоговые значения отчета
Field
Наименование поля таблицы, по которому будет вычисляться итоговое значение
в отчете
Sum
При установке в отчет будет помещена итоговая сумма поданному полю
Avg
При установке в отчет будет помещено итоговое среднее значение по данному
полю
Count При установке в отчет будет помещено итоговое количество строк
Min
При установке в отчет будет помещено минимальное значение поля таблицы
Max
При установке в отчет будет помещено максимальное значение поля таблицы
В диалоговом окне Summary Options (Итоговые опции) расположен переключатель, управляющий отображением в отчете областей данных
Detail and Summary В отчете отображается область данных, промежуточные итоговые значения по группировкам и конечные итоговые значения
по отчету
Summary only
В отчете отображается область данных и конечные итоговые
значения по отчету
No totals
В отчете будет отображаться только область данных
12. В следующем диалоговом
окне мастера задается стиль
отображения объектов в отчете
(Список Style (Стиль) содержит
несколько вариантов отображения объектов (полей, линий, заголовков и т. д.) в отчете. При
выборе стиля мастер позволяет
просмотреть, как будут выглядеть элементы отчета.) Выбрав
стиль, нажмите кнопку Next (Далее), чтобы перейти к следующему шагу.
13. На этом шаге создания отчета необходимо указать порядок размещения
объектов в отчете и ориентацию страницы отчета. После того как вы установили требуемые опции, нажмите кнопку Next (Далее).
14. На этом шаге создания отчета с помощью
мастера задаются поля,
по которым требуется
упорядочение данных в
отчете. Для формирования списка полей, по
которым будет осуществляться сортировка, из списка Available
fields or index tag (Выбранные поля и индексы), содержащего перечень всех
полей отчета и индексов таблицы, перенесите в список Selected fields (Выбранные поля) требуемые поля в том порядке, в каком будут упорядочиваться данные. Для переноса полей используйте кнопку Add(Добавить) или двойной щелчок мыши на наименовании поля.
15. На этом шаге вы можете
задать заголовок отчета, используя для этого поле ввода
Type a title for your report (Тип
заголовка отчета). Введя заголовок и установив требуемую
опцию, для завершения создания отчета с помощью мастера нажмите кнопку Finish (Готово).
Запросы к базе данных
Одним из основных назначений
разработанного приложения является быстрый поиск информации в базе данных и получение
ответов на разнообразные вопросы. Для этих целей в Visual
FoxPro используются средства,
называемые запросами. С помощью
конструктора
запросов
Visual FoxPro можно формировать различной сложности критерии для выбора записей из одной или не-
скольких таблиц, указывая при этом, какие поля должны быть отображены в
запросе. Над полями, выбираемыми из таблиц с помощью запросов, можно
выполнять различные вычисления.
Результатом запроса является таблица, которую вы можете сохранить в массиве, в создаваемой новой таблице, отобразить на экране в режиме Browse
(Просмотр) или вывести в виде отчета.
Для создания запросов вы можете использовать мастер запросов, который
последовательно запрашивает наименования таблиц, используемых в запросе, перечень полей таблиц, критерий упорядочения и условия фильтрации
данных.
Конструктор запросов
Для создания запроса в окне конструктора запросов выполните следующие
действия:
1. На вкладке Data (Данные) конструктора проекта выберите группу
Queries (Запросы).
2. Нажмите кнопку New (Новый).
3. В открывшемся диалоговом окне New Query (Новый запрос) нажмите
кнопку New Query (Новый запрос). Открывается диалоговое окно выбора таблиц Add Table or View (Добавить таблицу или представление
данных).
4. В этом диалоговом окне выберите таблицы, данные из которых хотите
использовать в запросе, и с помощью кнопки Add (Добавить) перенесите их в окно конструктора запросов.
5. Завершив выбор таблиц, нажмите кнопку Close (Закрыть).
На экране появляется окно конструктора запросов , которое содержит названия выбранных таблиц, а в основном меню появляется пункт Query (Запрос).
Можно приступать к формированию условий запроса.
Для открытия ранее созданного запроса в окне конструктора запросов на
вкладке Data (Данные) окна проекта в группе Queries (Запросы) найдите модифицируемый запрос, установите на него курсор и нажмите кнопку Modify
(Модифицировать).
Далее, открывая в конструкторе запросов необходимые вкладки, вы выполняете следующие действия:
•
выбираете поля результирующей таблицы запроса;
•
формируете вычисляемые поля;
•
указываете критерии для выборки, группировки и упорядочения данных;
•
задаете, куда выводить результат выборки.
В верхней части окна конструктора запросов расположена панель, на которой
отображаются используемые в запросе таблицы. Ниже находятся вкладки,
предназначенные для выбора полей запроса и формирования условий выборки.
Fields
Указывает поля исходных таблиц, выбираемые в результирующий запрос
Join
Задает условия объединения таблиц
Filter
Определяет фильтры, накладываемые для выбора записей
Order By
Позволяет задать критерии упорядочения данных
Group By
Позволяет задать условия группировки данных
Miscellaneous Позволяет задать дополнительные условия
Триггеры
В Visual FoxPro для таблиц, входящих в состав базы данных, вы можете
определить триггеры
Insert
Определяет действия, которые будут выполняться после добавления новой записи в таблицу
Update
Определяет действия, которые будут выполняться после изменения
записи таблицы
Delete
Определяет действия, которые будут выполняться после удаления
записи из таблицы
Для определения триггеров введите в поля ввода Insert trigger (Вставить триггер), Update trigger (Обновить триггер) или Delete trigger (Удалить триггер)
вкладки Table (Таблица) окна конструктора выбранной таблицы операторы
сравнения, вызов хранимой процедуры или любое логическое выражение.
Если результат вычисления выражения равен True (Истина), то считается, что
введены допустимые значения. В противном случае сохранения введенных
данных не происходит и формируется сообщение об ошибке. При использовании хранимых процедур вы сможете не только проверить условие достоверности ввода данных, но и задать действия, выполняемые при добавлении,
удалении и изменении данных.
Выводы и предложения
Современные системы управления базами данных, такие как IMS, Lotus Approach, Cetop, Oracle, Clipper, FoxPro, Access действительно являются мощным средством управления большим объемом данных. Они позволяют производить быструю сортировку большого массива данных, осуществлять
быстрый переход по записям в произвольном порядке, производить быструю
выборку большого количества данных из всего массива данных по заданным
критериям. В таких СУБД каждый файл данных рассматривается как двухмерная таблица, столбцы которой соответствуют полям записей, а строки соответствуют отдельным записям файла и обращение к данным идет через
указание номера записи имени поля. При этом работа с отдельным полем
таблицы данных напоминает работу с переменными – обращение к данным
максимально упрощено, и пользователю не нужно знать всю иерархическую
структуру данных.
К тому же язык команд этих систем управления базами данных содержит
широкий набор команд, выполняющих действия сложных конструкций,
например, сортировка записей файла сводится только к двум командам. Помимо этого в них предусмотрены команды создания светового меню для организации прямого диалога с пользователем. Все это максимально упрощает
написание программ и подтверждает, что современные системы управления
базами данных действительно являются мощным инструментом для создания
и обработки баз данных большого объема
Список использованной литературы
1. Н.Д Угринович «Информатика и информационные технологии»
2. О.Н. Леонова, И.А. Несмеянов «Компьютерный практикум. Программирование в среде Турбо-Паскаль и СУБД типа Fox»
3. А. В. Агибалов, Е.Ю. Горюхина «Автоматизированные системы обработки экономической информации»
Скачать